Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 28 Dec 2003 00:09:13 -0800
From:      Chip Wiegand <chip@wiegand.org>
To:        Dan Nelson <dnelson@allantgroup.com>
Cc:        questions@freebsd.org
Subject:   Re: ghostview missing libc.so.4?
Message-ID:  <3FEE8FA9.7030109@wiegand.org>
In-Reply-To: <20031228065845.GC51168@dan.emsphone.com>
References:  <3FEE5975.7060104@wiegand.org> <C258F32C-38F0-11D8-98AE-000A95BBCCF8@mac.com> <3FEE77BA.4060506@wiegand.org> <20031228065845.GC51168@dan.emsphone.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Dan Nelson wrote:

>In the last episode (Dec 27), Chip Wiegand said:
>  
>
>>Mine has libc.so.5. No wonder the app is failing, it specifically
>>wants .4 and is too dumb to work with anything newer. I'm getting
>>real frustrated with this again, I'd like to move away from MS but
>>it's not easy to do when the apps I need don't even work
>>properly.</rant>
>>    
>>
>
>Somehow you managed to install a FreeBSD 4 package onto a FreeBSD 5
>system.  pkg_delete it, then run "pkg_add -r ghostview" to fetch the
>correct package from ftp.freebsd.org, or cd into
>/usr/ports/print/ghostview and run "make install" if you want to build
>it yourself.
>  
>
Still one problem with doing that - after pkg_delete ghostview and 
pkg_add -r ghostview I get these errors -
cannot find ghostscipt in your path - install your favorite version of 
ghostscript, otherwise the program is useless
warning: package 'ghostview-1.5 ' requires 'imake-4.3.0' but found 
'imake-4.3.0_2'
warning: package 'ghostview-1.5  requires 'freetype2-2.1.4_1' but found 
'freetype2-2.1.5._1'
warning: package 'ghostview-1.5 requires 'fontconfig-2.2.0' but found 
'fontconfig-2.2.90_3'
warning: package 'ghostview-1.5 requires 'XFree86-libraries-4.3.0_5' but 
found 'XFree86-libraries-4.3.0_6'

I have ghostscript-gnu-7.07_4 installed.
This is really messed up.
--
Chip





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?3FEE8FA9.7030109>