From owner-svn-src-user@freebsd.org Thu Dec 13 06:37:37 2018 Return-Path: Delivered-To: svn-src-user@mailman.ysv.freebsd.org Received: from mx1.freebsd.org (mx1.freebsd.org [IPv6:2610:1c1:1:606c::19:1]) by mailman.ysv.freebsd.org (Postfix) with ESMTP id ED9DE130BE9C for ; Thu, 13 Dec 2018 06:37:36 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from mxrelay.nyi.freebsd.org (mxrelay.nyi.freebsd.org [IPv6:2610:1c1:1:606c::19:3]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) server-signature RSA-PSS (4096 bits) client-signature RSA-PSS (4096 bits) client-digest SHA256) (Client CN "mxrelay.nyi.freebsd.org", Issuer "Let's Encrypt Authority X3" (verified OK)) by mx1.freebsd.org (Postfix) with ESMTPS id 9323D70BA5; Thu, 13 Dec 2018 06:37:36 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from repo.freebsd.org (repo.freebsd.org [IPv6:2610:1c1:1:6068::e6a:0]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (Client did not present a certificate) by mxrelay.nyi.freebsd.org (Postfix) with ESMTPS id 764291BF63; Thu, 13 Dec 2018 06:37:36 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from repo.freebsd.org ([127.0.1.37]) by repo.freebsd.org (8.15.2/8.15.2) with ESMTP id wBD6baZ1076946; Thu, 13 Dec 2018 06:37:36 GMT (envelope-from pho@FreeBSD.org) Received: (from pho@localhost) by repo.freebsd.org (8.15.2/8.15.2/Submit) id wBD6baRF076945; Thu, 13 Dec 2018 06:37:36 GMT (envelope-from pho@FreeBSD.org) Message-Id: <201812130637.wBD6baRF076945@repo.freebsd.org> X-Authentication-Warning: repo.freebsd.org: pho set sender to pho@FreeBSD.org using -f From: Peter Holm Date: Thu, 13 Dec 2018 06:37:36 +0000 (UTC) To: src-committers@freebsd.org, svn-src-user@freebsd.org Subject: svn commit: r342027 - user/pho/stress2/misc X-SVN-Group: user X-SVN-Commit-Author: pho X-SVN-Commit-Paths: user/pho/stress2/misc X-SVN-Commit-Revision: 342027 X-SVN-Commit-Repository: base MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit X-Rspamd-Queue-Id: 9323D70BA5 X-Spamd-Bar: - Authentication-Results: mx1.freebsd.org X-Spamd-Result: default: False [-1.37 / 15.00]; local_wl_from(0.00)[FreeBSD.org]; NEURAL_HAM_MEDIUM(-0.79)[-0.789,0]; NEURAL_HAM_SHORT(-0.58)[-0.577,0]; ASN(0.00)[asn:11403, ipnet:2610:1c1:1::/48, country:US] X-BeenThere: svn-src-user@freebsd.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: "SVN commit messages for the experimental " user" src tree" List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Thu, 13 Dec 2018 06:37:37 -0000 Author: pho Date: Thu Dec 13 06:37:35 2018 New Revision: 342027 URL: https://svnweb.freebsd.org/changeset/base/342027 Log: Added a new test scenario for FFS extended attributes. PR: 230962 Added: user/pho/stress2/misc/extattr2.sh (contents, props changed) Added: user/pho/stress2/misc/extattr2.sh ============================================================================== --- /dev/null 00:00:00 1970 (empty, because file is newly added) +++ user/pho/stress2/misc/extattr2.sh Thu Dec 13 06:37:35 2018 (r342027) @@ -0,0 +1,89 @@ +#!/bin/sh + +# +# SPDX-License-Identifier: BSD-2-Clause-FreeBSD +# +# Copyright (c) 2018 Dell EMC Isilon +# +# Redistribution and use in source and binary forms, with or without +# modification, are permitted provided that the following conditions +# are met: +# 1. Redistributions of source code must retain the above copyright +# notice, this list of conditions and the following disclaimer. +# 2. Redistributions in binary form must reproduce the above copyright +# notice, this list of conditions and the following disclaimer in the +# documentation and/or other materials provided with the distribution. +# +# THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND +# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE +# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE +# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE +# FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL +# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS +# OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) +# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT +# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY +# OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF +# SUCH DAMAGE. +# +# $FreeBSD$ +# + +# [Bug 230962] Kernel panic when writing extended attributes with soft updates +# enabled. +# "panic: softdep_deallocate_dependencies: dangling deps" seen: +# https://people.freebsd.org/~pho/stress/log/kostik1121.txt + +[ `id -u ` -ne 0 ] && echo "Must be root!" && exit 1 + +. ../default.cfg +[ "`sysctl -in kern.features.ufs_extattr`" != "1" ] && exit 0 +[ -z "`which setfacl`" ] && exit 0 + +here=`pwd` +mount | grep "$mntpoint" | grep -q md${mdstart}$part && umount $mntpoint +mdconfig -l | grep -q md$mdstart && mdconfig -d -u $mdstart + +mdconfig -a -t swap -s 2g -u $mdstart +bsdlabel -w md$mdstart auto + +newfs $newfs_flags md${mdstart}$part > /dev/null +mount /dev/md${mdstart}$part $mntpoint + +mkdir -p $mntpoint/.attribute/system +cd $mntpoint/.attribute/system + +extattrctl initattr -p . 388 posix1e.acl_access +extattrctl initattr -p . 388 posix1e.acl_default +cd / +umount $mntpoint +tunefs -a enable /dev/md${mdstart}$part +mount /dev/md${mdstart}$part $mntpoint +mount | grep md${mdstart}$part + +export runRUNTIME=10m +export RUNDIR=$mntpoint/stressX +if [ `jot -r 1 0 1` -eq 1 ]; then + set `df -ik $mntpoint | tail -1 | awk '{print $4,$7}'` + export KBLOCKS=$(($1 / 2)) + export INODES=$(($2 / 2)) +fi + +mkdir -p $RUNDIR +chmod 0777 $RUNDIR +setfacl -b $RUNDIR +setfacl -m user:$testuser:rwx,group:$testuser:rwx $RUNDIR +su $testuser -c "cd $here/..; ./run.sh marcus.cfg" & + +sleep 5 +set -x +while pgrep -U$testuser -q -f run.sh; do + find $RUNDIR | xargs -P0 -J% setfacl -m user:$testuser:rwx,group:$testuser:rwx % > /dev/null 2>&1 +done +wait + +s=0 +umount $mntpoint +checkfs /dev/md${mdstart}$part || s=1 +mdconfig -d -u $mdstart || s=2 +exit $s From owner-svn-src-user@freebsd.org Thu Dec 13 06:51:21 2018 Return-Path: Delivered-To: svn-src-user@mailman.ysv.freebsd.org Received: from mx1.freebsd.org (mx1.freebsd.org [IPv6:2610:1c1:1:606c::19:1]) by mailman.ysv.freebsd.org (Postfix) with ESMTP id 72F16130C3EC for ; Thu, 13 Dec 2018 06:51:21 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from mxrelay.nyi.freebsd.org (mxrelay.nyi.freebsd.org [IPv6:2610:1c1:1:606c::19:3]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) server-signature RSA-PSS (4096 bits) client-signature RSA-PSS (4096 bits) client-digest SHA256) (Client CN "mxrelay.nyi.freebsd.org", Issuer "Let's Encrypt Authority X3" (verified OK)) by mx1.freebsd.org (Postfix) with ESMTPS id 198F4711E3; Thu, 13 Dec 2018 06:51:21 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from repo.freebsd.org (repo.freebsd.org [IPv6:2610:1c1:1:6068::e6a:0]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (Client did not present a certificate) by mxrelay.nyi.freebsd.org (Postfix) with ESMTPS id 0C9AF1C141; Thu, 13 Dec 2018 06:51:21 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from repo.freebsd.org ([127.0.1.37]) by repo.freebsd.org (8.15.2/8.15.2) with ESMTP id wBD6pKuU083943; Thu, 13 Dec 2018 06:51:20 GMT (envelope-from pho@FreeBSD.org) Received: (from pho@localhost) by repo.freebsd.org (8.15.2/8.15.2/Submit) id wBD6pKYI083942; Thu, 13 Dec 2018 06:51:20 GMT (envelope-from pho@FreeBSD.org) Message-Id: <201812130651.wBD6pKYI083942@repo.freebsd.org> X-Authentication-Warning: repo.freebsd.org: pho set sender to pho@FreeBSD.org using -f From: Peter Holm Date: Thu, 13 Dec 2018 06:51:20 +0000 (UTC) To: src-committers@freebsd.org, svn-src-user@freebsd.org Subject: svn commit: r342028 - user/pho/stress2/misc X-SVN-Group: user X-SVN-Commit-Author: pho X-SVN-Commit-Paths: user/pho/stress2/misc X-SVN-Commit-Revision: 342028 X-SVN-Commit-Repository: base MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit X-Rspamd-Queue-Id: 198F4711E3 X-Spamd-Bar: - Authentication-Results: mx1.freebsd.org X-Spamd-Result: default: False [-1.38 / 15.00]; local_wl_from(0.00)[FreeBSD.org]; NEURAL_HAM_MEDIUM(-0.79)[-0.793,0]; NEURAL_HAM_SHORT(-0.58)[-0.584,0]; ASN(0.00)[asn:11403, ipnet:2610:1c1:1::/48, country:US] X-BeenThere: svn-src-user@freebsd.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: "SVN commit messages for the experimental " user" src tree" List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Thu, 13 Dec 2018 06:51:21 -0000 Author: pho Date: Thu Dec 13 06:51:20 2018 New Revision: 342028 URL: https://svnweb.freebsd.org/changeset/base/342028 Log: Cleanup: remove debug code. Sponsored by: Dell EMC Isilon Modified: user/pho/stress2/misc/extattr2.sh Modified: user/pho/stress2/misc/extattr2.sh ============================================================================== --- user/pho/stress2/misc/extattr2.sh Thu Dec 13 06:37:35 2018 (r342027) +++ user/pho/stress2/misc/extattr2.sh Thu Dec 13 06:51:20 2018 (r342028) @@ -76,7 +76,6 @@ setfacl -m user:$testuser:rwx,group:$testuser:rwx $RUN su $testuser -c "cd $here/..; ./run.sh marcus.cfg" & sleep 5 -set -x while pgrep -U$testuser -q -f run.sh; do find $RUNDIR | xargs -P0 -J% setfacl -m user:$testuser:rwx,group:$testuser:rwx % > /dev/null 2>&1 done From owner-svn-src-user@freebsd.org Thu Dec 13 11:49:12 2018 Return-Path: Delivered-To: svn-src-user@mailman.ysv.freebsd.org Received: from mx1.freebsd.org (mx1.freebsd.org [IPv6:2610:1c1:1:606c::19:1]) by mailman.ysv.freebsd.org (Postfix) with ESMTP id DB7BC1318B68 for ; Thu, 13 Dec 2018 11:49:12 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from mxrelay.nyi.freebsd.org (mxrelay.nyi.freebsd.org [IPv6:2610:1c1:1:606c::19:3]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) server-signature RSA-PSS (4096 bits) client-signature RSA-PSS (4096 bits) client-digest SHA256) (Client CN "mxrelay.nyi.freebsd.org", Issuer "Let's Encrypt Authority X3" (verified OK)) by mx1.freebsd.org (Postfix) with ESMTPS id 8239C8455D; Thu, 13 Dec 2018 11:49:12 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from repo.freebsd.org (repo.freebsd.org [IPv6:2610:1c1:1:6068::e6a:0]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (Client did not present a certificate) by mxrelay.nyi.freebsd.org (Postfix) with ESMTPS id 6FE471F504; Thu, 13 Dec 2018 11:49:12 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from repo.freebsd.org ([127.0.1.37]) by repo.freebsd.org (8.15.2/8.15.2) with ESMTP id wBDBnCUI040058; Thu, 13 Dec 2018 11:49:12 GMT (envelope-from pho@FreeBSD.org) Received: (from pho@localhost) by repo.freebsd.org (8.15.2/8.15.2/Submit) id wBDBnCHk040057; Thu, 13 Dec 2018 11:49:12 GMT (envelope-from pho@FreeBSD.org) Message-Id: <201812131149.wBDBnCHk040057@repo.freebsd.org> X-Authentication-Warning: repo.freebsd.org: pho set sender to pho@FreeBSD.org using -f From: Peter Holm Date: Thu, 13 Dec 2018 11:49:12 +0000 (UTC) To: src-committers@freebsd.org, svn-src-user@freebsd.org Subject: svn commit: r342043 - user/pho/stress2/misc X-SVN-Group: user X-SVN-Commit-Author: pho X-SVN-Commit-Paths: user/pho/stress2/misc X-SVN-Commit-Revision: 342043 X-SVN-Commit-Repository: base MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit X-Rspamd-Queue-Id: 8239C8455D X-Spamd-Bar: - Authentication-Results: mx1.freebsd.org X-Spamd-Result: default: False [-1.29 / 15.00]; local_wl_from(0.00)[FreeBSD.org]; NEURAL_HAM_MEDIUM(-0.79)[-0.793,0]; NEURAL_HAM_SHORT(-0.50)[-0.495,0]; ASN(0.00)[asn:11403, ipnet:2610:1c1:1::/48, country:US] X-BeenThere: svn-src-user@freebsd.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: "SVN commit messages for the experimental " user" src tree" List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Thu, 13 Dec 2018 11:49:13 -0000 Author: pho Date: Thu Dec 13 11:49:12 2018 New Revision: 342043 URL: https://svnweb.freebsd.org/changeset/base/342043 Log: Try harder to unmount the FS. Sponsored by: Dell EMC Isilon Modified: user/pho/stress2/misc/extattr2.sh Modified: user/pho/stress2/misc/extattr2.sh ============================================================================== --- user/pho/stress2/misc/extattr2.sh Thu Dec 13 11:18:45 2018 (r342042) +++ user/pho/stress2/misc/extattr2.sh Thu Dec 13 11:49:12 2018 (r342043) @@ -82,7 +82,12 @@ done wait s=0 -umount $mntpoint +for i in `jot 6`; do + mount | grep -q "on $mntpoint " || break + umount $mntpoint && break || sleep 10 + [ $i -eq 6 ] && + { echo FAIL; fstat -mf $mntpoint; exit 1; } +done checkfs /dev/md${mdstart}$part || s=1 mdconfig -d -u $mdstart || s=2 exit $s From owner-svn-src-user@freebsd.org Thu Dec 13 11:55:20 2018 Return-Path: Delivered-To: svn-src-user@mailman.ysv.freebsd.org Received: from mx1.freebsd.org (mx1.freebsd.org [IPv6:2610:1c1:1:606c::19:1]) by mailman.ysv.freebsd.org (Postfix) with ESMTP id ABD2D1318EA4 for ; Thu, 13 Dec 2018 11:55:20 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from mxrelay.nyi.freebsd.org (mxrelay.nyi.freebsd.org [IPv6:2610:1c1:1:606c::19:3]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) server-signature RSA-PSS (4096 bits) client-signature RSA-PSS (4096 bits) client-digest SHA256) (Client CN "mxrelay.nyi.freebsd.org", Issuer "Let's Encrypt Authority X3" (verified OK)) by mx1.freebsd.org (Postfix) with ESMTPS id 4F043849E5; Thu, 13 Dec 2018 11:55:20 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from repo.freebsd.org (repo.freebsd.org [IPv6:2610:1c1:1:6068::e6a:0]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (Client did not present a certificate) by mxrelay.nyi.freebsd.org (Postfix) with ESMTPS id 429891F6A9; Thu, 13 Dec 2018 11:55:20 +0000 (UTC) (envelope-from pho@FreeBSD.org) Received: from repo.freebsd.org ([127.0.1.37]) by repo.freebsd.org (8.15.2/8.15.2) with ESMTP id wBDBtKs1045408; Thu, 13 Dec 2018 11:55:20 GMT (envelope-from pho@FreeBSD.org) Received: (from pho@localhost) by repo.freebsd.org (8.15.2/8.15.2/Submit) id wBDBtIme045401; Thu, 13 Dec 2018 11:55:18 GMT (envelope-from pho@FreeBSD.org) Message-Id: <201812131155.wBDBtIme045401@repo.freebsd.org> X-Authentication-Warning: repo.freebsd.org: pho set sender to pho@FreeBSD.org using -f From: Peter Holm Date: Thu, 13 Dec 2018 11:55:18 +0000 (UTC) To: src-committers@freebsd.org, svn-src-user@freebsd.org Subject: svn commit: r342044 - user/pho/stress2/misc X-SVN-Group: user X-SVN-Commit-Author: pho X-SVN-Commit-Paths: user/pho/stress2/misc X-SVN-Commit-Revision: 342044 X-SVN-Commit-Repository: base MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit X-Rspamd-Queue-Id: 4F043849E5 X-Spamd-Bar: - Authentication-Results: mx1.freebsd.org X-Spamd-Result: default: False [-1.29 / 15.00]; local_wl_from(0.00)[FreeBSD.org]; NEURAL_HAM_MEDIUM(-0.79)[-0.789,0]; NEURAL_HAM_SHORT(-0.50)[-0.500,0]; ASN(0.00)[asn:11403, ipnet:2610:1c1:1::/48, country:US] X-BeenThere: svn-src-user@freebsd.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: "SVN commit messages for the experimental " user" src tree" List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Thu, 13 Dec 2018 11:55:20 -0000 Author: pho Date: Thu Dec 13 11:55:18 2018 New Revision: 342044 URL: https://svnweb.freebsd.org/changeset/base/342044 Log: Wait for the mirror name to appear in /dev/mirror if launch_mirror_before_timeout is" 0". Sponsored by: Dell EMC Isilon Modified: user/pho/stress2/misc/graid1.sh user/pho/stress2/misc/graid1_10.sh user/pho/stress2/misc/graid1_2.sh user/pho/stress2/misc/graid1_4.sh user/pho/stress2/misc/graid1_5.sh user/pho/stress2/misc/graid1_6.sh user/pho/stress2/misc/graid1_7.sh user/pho/stress2/misc/graid1_9.sh Modified: user/pho/stress2/misc/graid1.sh ============================================================================== --- user/pho/stress2/misc/graid1.sh Thu Dec 13 11:49:12 2018 (r342043) +++ user/pho/stress2/misc/graid1.sh Thu Dec 13 11:55:18 2018 (r342044) @@ -54,6 +54,8 @@ sysctl kern.geom.mirror.debug=-1 | grep -q -- -1 || sysctl kern.geom.mirror.debug=$old > /dev/null gmirror label -v -b split -s 2048 data /dev/md$md1 /dev/md$md2 \ /dev/md$md3 > /dev/null || exit 1 +[ "`sysctl -in kern.geom.mirror.launch_mirror_before_timeout`" = "0" ] && + sleep $((`sysctl -n kern.geom.mirror.timeout` + 1)) [ -c /dev/mirror/data ] || exit 1 newfs $newfs_flags /dev/mirror/data > /dev/null mount /dev/mirror/data $mntpoint Modified: user/pho/stress2/misc/graid1_10.sh ============================================================================== --- user/pho/stress2/misc/graid1_10.sh Thu Dec 13 11:49:12 2018 (r342043) +++ user/pho/stress2/misc/graid1_10.sh Thu Dec 13 11:55:18 2018 (r342044) @@ -55,6 +55,8 @@ sysctl kern.geom.mirror.debug=-1 | grep -q -- -1 || sysctl kern.geom.mirror.debug=$old > /dev/null gmirror label -v -b split -s 2048 test /dev/md$md1 /dev/md$md2 \ > /dev/null || exit 1 +[ "`sysctl -in kern.geom.mirror.launch_mirror_before_timeout`" = "0" ] && + sleep $((`sysctl -n kern.geom.mirror.timeout` + 1)) [ -c /dev/mirror/test ] || exit 1 newfs /dev/mirror/test > /dev/null mount /dev/mirror/test $mntpoint Modified: user/pho/stress2/misc/graid1_2.sh ============================================================================== --- user/pho/stress2/misc/graid1_2.sh Thu Dec 13 11:49:12 2018 (r342043) +++ user/pho/stress2/misc/graid1_2.sh Thu Dec 13 11:55:18 2018 (r342044) @@ -62,6 +62,8 @@ for u in $md1 $md2; do mdconfig -a -t vnode -f /tmp/graid1_2_di$u -u $u done gmirror label test /dev/md$md1 /dev/md$md2 || exit 1 +[ "`sysctl -in kern.geom.mirror.launch_mirror_before_timeout`" = "0" ] && + sleep $((`sysctl -n kern.geom.mirror.timeout` + 1)) [ -c /dev/mirror/test ] || exit 1 for i in `jot 150`; do /tmp/graid1_2 /dev/mirror/test; done & Modified: user/pho/stress2/misc/graid1_4.sh ============================================================================== --- user/pho/stress2/misc/graid1_4.sh Thu Dec 13 11:49:12 2018 (r342043) +++ user/pho/stress2/misc/graid1_4.sh Thu Dec 13 11:55:18 2018 (r342044) @@ -63,6 +63,8 @@ done gmirror label -v -b split -s 2048 test /dev/md$md1 /dev/md$md2 \ > /dev/null || exit 1 +[ "`sysctl -in kern.geom.mirror.launch_mirror_before_timeout`" = "0" ] && + sleep $((`sysctl -n kern.geom.mirror.timeout` + 1)) [ -c /dev/mirror/test ] || exit 1 # Soft Updates issues with removal of backing media newfs /dev/mirror/test > /dev/null Modified: user/pho/stress2/misc/graid1_5.sh ============================================================================== --- user/pho/stress2/misc/graid1_5.sh Thu Dec 13 11:49:12 2018 (r342043) +++ user/pho/stress2/misc/graid1_5.sh Thu Dec 13 11:55:18 2018 (r342044) @@ -64,6 +64,8 @@ gpart add -t freebsd-ufs -s 340m md$u3 gnop create md$u2 gnop create md$u3 gmirror label test md${u1}p1 md$u2.nopp1 md$u3.nopp1 +[ "`sysctl -in kern.geom.mirror.launch_mirror_before_timeout`" = "0" ] && + sleep $((`sysctl -n kern.geom.mirror.timeout` + 1)) [ -c /dev/mirror/test ] || exit 1 newfs /dev/mirror/test > /dev/null Modified: user/pho/stress2/misc/graid1_6.sh ============================================================================== --- user/pho/stress2/misc/graid1_6.sh Thu Dec 13 11:49:12 2018 (r342043) +++ user/pho/stress2/misc/graid1_6.sh Thu Dec 13 11:55:18 2018 (r342044) @@ -59,6 +59,8 @@ done gmirror label -v -b split -s 2048 test /dev/md$md1 /dev/md$md2 \ > /dev/null || exit 1 +[ "`sysctl -in kern.geom.mirror.launch_mirror_before_timeout`" = "0" ] && + sleep $((`sysctl -n kern.geom.mirror.timeout` + 1)) [ -c /dev/mirror/test ] || exit 1 newfs $newfs_flags /dev/mirror/test > /dev/null mount /dev/mirror/test $mntpoint Modified: user/pho/stress2/misc/graid1_7.sh ============================================================================== --- user/pho/stress2/misc/graid1_7.sh Thu Dec 13 11:49:12 2018 (r342043) +++ user/pho/stress2/misc/graid1_7.sh Thu Dec 13 11:55:18 2018 (r342044) @@ -58,6 +58,8 @@ gpart add -t freebsd-ufs -s 341m md$u1 gpart add -t freebsd-ufs -s 341m md$u1 ) > /dev/null gmirror label test md${u1}p1 md${u1}p2 md${u1}p3 +[ "`sysctl -in kern.geom.mirror.launch_mirror_before_timeout`" = "0" ] && + sleep $((`sysctl -n kern.geom.mirror.timeout` + 1)) [ -c /dev/mirror/test ] || exit 1 newfs /dev/mirror/test > /dev/null Modified: user/pho/stress2/misc/graid1_9.sh ============================================================================== --- user/pho/stress2/misc/graid1_9.sh Thu Dec 13 11:49:12 2018 (r342043) +++ user/pho/stress2/misc/graid1_9.sh Thu Dec 13 11:55:18 2018 (r342044) @@ -59,6 +59,8 @@ sysctl kern.geom.mirror.debug=-1 | grep -q -- -1 || sysctl kern.geom.mirror.debug=$old > /dev/null gmirror label -v -b split -s 2048 test /dev/md$md1 /dev/md$md2 \ /dev/md$md3 > /dev/null || exit 1 +[ "`sysctl -in kern.geom.mirror.launch_mirror_before_timeout`" = "0" ] && + sleep $((`sysctl -n kern.geom.mirror.timeout` + 1)) [ -c /dev/mirror/test ] || exit 1 # Do not use SU as it is more intolerant to FS corruption newfs /dev/mirror/test > /dev/null