Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 6 Mar 2021 19:42:27 -0500
From:      David Mehler <dave.mehler@gmail.com>
To:        freebsd-questions <freebsd-questions@freebsd.org>
Subject:   acme.sh issue, cert date invalid, but no errors from letsencrypt
Message-ID:  <CAPORhP6xi2Kf7iQ8BxQNeezycGHOw+nSqn6x9hX8mz-wzjakLQ@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hello,

I'm using acme.sh on FreeBSD 12.2 renewing letsencrypt certificates. I
don't get an error issuing or renewing the certificate from
letsencrypt and I don't get any errors when atempting to deploy the
scripts in to the location where the web server detects them.

The problem comes when I atempt to access the site and I keep getting
from chrome a privacy message, and it says that the cert date is
invalid. So I go to where the .crt file is and do

openssl x509 -in serverKeyName.crt -noout -text

I checked the not before date and it shows not before August 2020. The
not-after date on the .crt file is November 2020, which I'm assuming
is my problem, but I don't understand why issue, renew, or deploy
isn't giving me a new key.

Any ideas?

Thanks.
DAve.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAPORhP6xi2Kf7iQ8BxQNeezycGHOw+nSqn6x9hX8mz-wzjakLQ>