Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 19 Nov 2009 15:55:14 -0600
From:      Adam Vande More <amvandemore@gmail.com>
To:        "Michael W. Lucas" <mwlucas@blackhelicopters.org>
Cc:        questions@freebsd.org
Subject:   Re: diskless problem: Lookup of /dev for devfs, error: 13
Message-ID:  <6201873e0911191355l6c872cfat235e16b4184b02fd@mail.gmail.com>
In-Reply-To: <20091119211829.GA86841@bewilderbeast.blackhelicopters.org>
References:  <20091119211829.GA86841@bewilderbeast.blackhelicopters.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Thu, Nov 19, 2009 at 3:18 PM, Michael W. Lucas <
mwlucas@blackhelicopters.org> wrote:

>
> Hi,
>
> I'm attempting to run a diskless 8.0 i386 workstation on VMWare, using
> an OpenSolaris box as a file store.  I get PXE, the kernel loads, but
> when we try to remount the filesystem I get:
>
> ...
> NFS ROOT:  XXX.XXX.XXX.XXX:/storage1/vm/netflow
> Lookup of /dev for devfs, error 13
> exec /sbin/init: error 13
> exec /sbin/oinit: error 13
> exec /sbin/init.bak: error 13
> exec /rescue/inet: error 13
> exec /stand/sysinstall: error 13
> init: not found in path
> ...
>
> At first glance, it would appear that /dev is missing.  I've never
> seen this happen before diskless systems, though, and I can't find any
> other references to this.  I know that other people have PXE-booted
> FreeBSD on VMWare, however.
>
> Anyone have any suggestions on what to check?
>
> Thanks,
>
>
I think you were following the same aged howto I was.  Whatever config file
/stand/sysinstall and friends is located in needs to be edited and have
those references removed.  That's about as far as I got when playing around
a few ago.

-- 
Adam Vande More



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?6201873e0911191355l6c872cfat235e16b4184b02fd>