Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 10 Nov 2010 23:55:02 +0100
From:      "Hasse Hansson" <hasse@thorshammare.org>
To:        "'Hasse Hansson'" <hasse@thorshammare.org>, <freebsd-questions@freebsd.org>
Subject:   SV: Problems updating IonCube
Message-ID:  <000001cb812a$52a9cb60$f7fd6220$@org>
In-Reply-To: <000001cb810f$7e3387f0$7a9a97d0$@org>
References:  <000001cb810f$7e3387f0$7a9a97d0$@org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help


-----Oprindelig meddelelse-----
Fra: owner-freebsd-questions@freebsd.org
[mailto:owner-freebsd-questions@freebsd.org] P=E5 vegne af Hasse Hansson
Sendt: den 10 november 2010 20:43
Til: freebsd-questions@freebsd.org
Emne: VS: Problems updating IonCube

=20

=20

Fra: Hasse Hansson [mailto:hasse@thorshammare.org]=20
Sendt: den 10 november 2010 20:13
Til: 'owner-freebsd-questions@freebsd.org'
Emne: Problems updating IonCube

=20

Hello all

=20

This is what's happening when I try to update devel/ioncube

-------------------------------------------------

odin# portupgrade -r ioncube

--->  Upgrading 'ioncube-3.3.19' to 'ioncube-4.0.1' (devel/ioncube)

--->  Building '/usr/ports/devel/ioncube'

=3D=3D=3D>  Cleaning for ioncube-4.0.1

=3D=3D=3D>  License check disabled, port has not defined LICENSE

=3D=3D=3D>  Extracting for ioncube-4.0.1

=3D> SHA256 Checksum mismatch for ioncube_loaders_fre_8_x86.tar.gz.

=3D=3D=3D>  Refetch for 1 more times files: =
ioncube_loaders_fre_8_x86.tar.gz

=3D=3D=3D>  License check disabled, port has not defined LICENSE

=3D> ioncube_loaders_fre_8_x86.tar.gz doesn't seem to exist in
/usr/ports/distfiles/.

=3D> Attempting to fetch from =
http://downloads2.ioncube.com/loader_downloads/.

fetch:
http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_fre_8_x86.=
tar
.gz: Requested Range Not Satisfiable

=3D> Attempting to fetch from =
http://dl.dropbox.com/u/4211495/ioncube/4.0.1/.

fetch:
http://dl.dropbox.com/u/4211495/ioncube/4.0.1/ioncube_loaders_fre_8_x86.t=
ar.
gz: size mismatch: expected 2883104, actual 0

=3D> Attempting to fetch from
ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/.

fetch:
ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/ioncube_loaders_fre_8_x=
86.
tar.gz: size mismatch: expected 2883104, actual 2737048

=3D> Couldn't fetch it - please try to retrieve this

=3D> port manually into /usr/ports/distfiles/ and try again.

*** Error code 1

=20

Stop in /usr/ports/devel/ioncube.

*** Error code 1

=20

Stop in /usr/ports/devel/ioncube.

** Command failed [exit code 1]: /usr/bin/script -qa
/tmp/portupgrade20101110-27671-zakjfx-0 env UPGRADE_TOOL=3Dportupgrade
UPGRADE_PORT=3Dioncube-3.3.19 UPGRADE_PORT_VER=3D3.3.19 make

** Fix the problem and try again.

** Listing the failed packages (-:ignored / *:skipped / !:failed)

        ! devel/ioncube (ioncube-3.3.19)        (checksum mismatch)

=20

Any tips ?

=20

Best Regards

Hasse Hansson

=20

=20
Yes, that did it, but not without protests :-)
Could this have anything to do with that I recently downgraded my php
install to 5.2.14 to also be able to run ZendOptimazer ?

odin# portupgrade -D r ioncube
--->  Upgrading 'ioncube-3.3.19' to 'ioncube-4.0.1' (devel/ioncube)
--->  Building '/usr/ports/devel/ioncube'
=3D=3D=3D>  Cleaning for ioncube-4.0.1
=3D=3D=3D>  License check disabled, port has not defined LICENSE
=3D=3D=3D>  Extracting for ioncube-4.0.1
=3D> SHA256 Checksum mismatch for ioncube_loaders_fre_8_x86.tar.gz.
=3D=3D=3D>  Refetch for 1 more times files: =
ioncube_loaders_fre_8_x86.tar.gz
=3D=3D=3D>  License check disabled, port has not defined LICENSE
=3D> ioncube_loaders_fre_8_x86.tar.gz doesn't seem to exist in
/usr/ports/distfiles/.
=3D> Attempting to fetch from =
http://downloads2.ioncube.com/loader_downloads/.
fetch:
http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_fre_8_x86.=
tar
.gz: Requested Range Not Satisfiable
=3D> Attempting to fetch from =
http://dl.dropbox.com/u/4211495/ioncube/4.0.1/.
fetch:
http://dl.dropbox.com/u/4211495/ioncube/4.0.1/ioncube_loaders_fre_8_x86.t=
ar.
gz: size mismatch: expected 2883104, actual 0
=3D> Attempting to fetch from
ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/.
fetch:
ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/ioncube_loaders_fre_8_x=
86.
tar.gz: size mismatch: expected 2883104, actual 2737048
=3D> Couldn't fetch it - please try to retrieve this
=3D> port manually into /usr/ports/distfiles/ and try again.
*** Error code 1

Stop in /usr/ports/devel/ioncube.
*** Error code 1

Stop in /usr/ports/devel/ioncube.
--->  Retrying devel/ioncube
--->  Deleting mismatched files
++ Deleting /usr/ports/distfiles/ioncube_loaders_fre_8_x86.tar.gz
--->  Building '/usr/ports/devel/ioncube'
=3D=3D=3D>  Cleaning for ioncube-4.0.1
=3D=3D=3D>  License check disabled, port has not defined LICENSE
=3D> ioncube_loaders_fre_8_x86.tar.gz doesn't seem to exist in
/usr/ports/distfiles/.
=3D> Attempting to fetch from =
http://downloads2.ioncube.com/loader_downloads/.
ioncube_loaders_fre_8_x86.tar.gz              100% of 2815 kB  758 kBps
=3D=3D=3D>  Extracting for ioncube-4.0.1
=3D> SHA256 Checksum OK for ioncube_loaders_fre_8_x86.tar.gz.
=3D=3D=3D>  Patching for ioncube-4.0.1
=3D=3D=3D>  Configuring for ioncube-4.0.1
--->  Backing up the old version
--->  Uninstalling the old version
--->  Deinstalling 'ioncube-3.3.19'
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 766 packages
found (-1 +0) (...) done]
--->  Installing the new version via the port
=3D=3D=3D>  Installing for ioncube-4.0.1
=3D=3D=3D>   ioncube-4.0.1 depends on file: =
/usr/local/include/php/main/php.h -
found
=3D=3D=3D>   Generating temporary packing list
=3D=3D=3D>  Checking if devel/ioncube already installed
install  -o root -g wheel -m 444
/usr/ports/devel/ioncube/work/ioncube/ioncube_loader_fre_5.2.so
/usr/local/lib/php/20060613/ioncube/ioncube_loader.so
install  -o root -g wheel -m 444
/usr/ports/devel/ioncube/work/ioncube/ioncube_loader_fre_5.2_ts.so
/usr/local/lib/php/20060613/ioncube/ioncube_loader_ts.so

You have installed the ionCube loader package.

Edit /usr/local/etc/php.ini or /usr/local/etc/php/extensions.ini
and add this three lines:

-------------------------------------------------------------------------=
---
----
[Zend]
zend_extension=3D"/usr/local/lib/php/20060613/ioncube/ioncube_loader.so"
zend_extension_ts=3D"/usr/local/lib/php/20060613/ioncube/ioncube_loader_t=
s.so"
-------------------------------------------------------------------------=
---
----

NOTE: If you have any Zend Extension already installed - you need put =
this
before
existing zend_extension lines.

Note: FreeBSD 6.x depricated and will be unsupported in the next port
release.
=3D=3D=3D>   Registering installation for ioncube-4.0.1
=3D=3D=3D>  Cleaning for ioncube-4.0.1
--->  Cleaning out obsolete shared libraries

/Hasse




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?000001cb812a$52a9cb60$f7fd6220$>