Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 19 Nov 2009 14:05:01 -0800 (PST)
From:      Richard Mahlerwein <mahlerrd@yahoo.com>
To:        FreeBSD-Questions <freebsd-questions@freebsd.org>
Subject:   Re: Apache22 + Subversion 1.6.6 = No go.
Message-ID:  <75307.92894.qm@web51011.mail.re2.yahoo.com>
In-Reply-To: <6b6f6c5e02e38af4ded7a3884301c1ac@verizon.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
=0A=0A--- On Thu, 11/19/09, Glen Johnson <nelgmj@verizon.net> wrote:=0A=0A>=
 >> 1 I tried chmod -R 777 /home/svn/repos.=0A> >> normal operations=0A> >>=
 [Thu Nov 19 09:36:10 2009] [error] [client=0A> 192.168.2.12] (20014)Intern=
al=0A> >> error: Can't open file=0A> '/usr/home/svn/repos/default/format': =
No such=0A> >> file or directory=0A> >> [Thu Nov 19 09:36:10 2009] [error] =
[client=0A> 192.168.2.12] Could not fetch=0A> >> resource information.=A0 [=
500, #0]=0A> >> [Thu Nov 19 09:36:10 2009] [error] [client=0A> 192.168.2.12=
] Could not open=0A> >> the requested SVN filesystem=A0 [500, #2]=0A=0A> > =
Please post the relevant bits from your httpd.conf=0A> where you set up the=
=0A> > SVNPath, etc.=A0 It looks like maybe the SVNPath=0A> directive is po=
inting to=0A> > the wrong place.=0A> > =0A> Thanks for your reply.=A0 I cur=
rently have this info in=0A> /usr/local/etc/apache22/Includes/svn.conf.=A0 =
Apache22=0A> loads all the conf files in this directory when httpd.conf=0A>=
 is loaded.=0A> <Location /svn>=0A> =A0 =A0 =A0 =A0 DAV svn=0A> =A0 =A0 =A0=
 =A0 SVNParentPath /usr/home/svn/repos=0A> =A0 =A0 =A0 =A0 SVNListParentPat=
h on=0A> =A0 =A0 =A0 =A0 SVNPathAuthz off=0A> =A0 =A0 =A0 =A0 SVNIndexXSLT =
"/data-dist/svnindex.xsl"=0A> =0A> =A0 =A0 =A0 =A0 # anonymous first=0A> =
=A0 =A0 =A0 =A0 Satisfy Any=0A> =A0 =A0 =A0 =A0 Require valid-user=0A> =0A>=
 =A0 =A0 =A0 =A0 # authenticating them valid ones=0A> =A0 =A0 =A0 =A0 AuthT=
ype Basic=0A> =A0 =A0 =A0 =A0 AuthName "Subversion Repositories"=0A> =A0 =
=A0 =A0 =A0 AuthUserFile /usr/home/svn/access/users=0A> </Location>=0A=0AHe=
re's one of mine that I think I've minimally modded to fit your paths.  Cou=
ld you try dropping that into place and see if it fails?  That would at lea=
st cut down the places it may go wrong (e.g. SVNParentPath...).  You'll nee=
d to htpasswd a new user into the "new" AuthUserFile.  Then try the /test a=
nd see what happens.=0A=0A<Location /test>=0A        DAV svn=0A        SVNP=
ath   /usr/home/svn/repos/<FIXME_TO_A_SVN_DIR>=0A        AuthType Basic=0A =
       AuthName "Documentation Repository"=0A        AuthUserFile /usr/home=
/svn/access/users.new=0A=0A        <LimitExcept GET PROPFIND OPTIONS REPORT=
>=0A          Require valid-user=0A        </LimitExcept>=0A</Location>=0A=
=0A-Rich=0A=0A=0A      



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?75307.92894.qm>