Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 2 May 2007 20:41:23 +0000 (GMT)
From:      AN <andy@neu.net>
To:        cups@easysw.com, freebsd-gnome@freebsd.org, freebsd-questions@freebsd.org
Subject:   cups permission problems
Message-ID:  <20070502201724.O88357@neu.net>

Next in thread | Raw E-Mail | Index | Archive | Help
I just installed cups 1.2.10 on FBSD 6.2 stable from ports.  The install 
completed successfully, however when I try to do anything nothing works. 
After starting the cups daemon, I go to localhost:631 and I can see the 
main page but when I try to add a printer the page is blank.  The 
following are excerpts from /var/log/cups/error_log:

I [02/May/2007:22:44:46 +0300] Full reload complete.
I [02/May/2007:22:44:46 +0300] Listening to ::1:631 on fd 2...
I [02/May/2007:22:44:46 +0300] Listening to 127.0.0.1:631 on fd 3...
I [02/May/2007:22:44:46 +0300] Listening to /var/run/cups.sock on fd 4...
I [02/May/2007:22:45:04 +0300] commptr="?OP=add-printer"
I [02/May/2007:22:45:04 +0300] Started 
"/usr/local/libexec/cups/cgi-bin/admin.cgi" (pid=89759)
E [02/May/2007:22:45:04 +0300] [CGI] Unable to open template file 
"/usr/local/share/cups/templates/header.tmpl" - Permission denied
E [02/May/2007:22:45:04 +0300] [CGI] Unable to open template file 
"/usr/local/share/cups/templates/add-printer.tmpl" - Permission denied
E [02/May/2007:22:45:04 +0300] [CGI] Unable to open template file 
"/usr/local/share/cups/templates/trailer.tmpl" - Permission denied
I [02/May/2007:22:48:13 +0300] Full reload complete.
I [02/May/2007:22:48:13 +0300] Listening to ::1:631 on fd 1...
I [02/May/2007:22:48:13 +0300] Listening to 127.0.0.1:631 on fd 3...
I [02/May/2007:22:48:13 +0300] Listening to /var/run/cups.sock on fd 4...
I [02/May/2007:22:53:32 +0300] commptr="?OP=add-printer"
I [02/May/2007:22:53:32 +0300] Started 
"/usr/local/libexec/cups/cgi-bin/admin.cgi" (pid=89770)
E [02/May/2007:22:53:32 +0300] [CGI] Unable to open template file 
"/usr/local/share/cups/templates/header.tmpl" - Permission denied
E [02/May/2007:22:53:32 +0300] [CGI] Unable to open template file 
"/usr/local/share/cups/templates/add-printer.tmpl" - Permission denied
E [02/May/2007:22:53:32 +0300] [CGI] Unable to open template file 
"/usr/local/share/cups/templates/trailer.tmpl" - Permission denied
I [02/May/2007:22:55:10 +0300] Saving remote.cache...
I [02/May/2007:22:56:18 +0300] Full reload complete.
E [02/May/2007:22:56:19 +0300] Unable to bind socket for address ::1:631 - 
Address already in use.
E [02/May/2007:22:56:19 +0300] Unable to bind socket for address 
127.0.0.1:631 - Address already in use.
I [02/May/2007:22:56:19 +0300] Listening to /var/run/cups.sock on fd 2...
E [02/May/2007:22:56:19 +0300] cupsdStartBrowsing: Unable to bind 
broadcast socket - Address already in use.
I [02/May/2007:22:58:22 +0300] Listening to ::1:631 (IPv6)
I [02/May/2007:22:58:22 +0300] Listening to 127.0.0.1:631 (IPv4)
I [02/May/2007:22:58:22 +0300] Listening to /var/run/cups.sock (Domain)
I [02/May/2007:22:58:22 +0300] Loaded configuration file 
"/usr/local/etc/cups/cupsd.conf"
I [02/May/2007:22:58:22 +0300] Using default TempDir of 
/var/spool/cups/tmp...
I [02/May/2007:22:58:22 +0300] Cleaning out old temporary files in 
"/var/spool/cups/tmp"...
I [02/May/2007:22:58:22 +0300] Configured for up to 100 clients.
I [02/May/2007:22:58:22 +0300] Allowing up to 100 client connections per 
host.
I [02/May/2007:22:58:22 +0300] Using policy "default" as the default!
I [02/May/2007:22:58:22 +0300] Full reload is required.
I [02/May/2007:22:58:22 +0300] Loaded MIME database from 
'/usr/local/etc/cups': 34 types, 38 filters...
I [02/May/2007:22:58:22 +0300] Loading job cache file 
"/var/cache/cups/job.cache"...
I [02/May/2007:22:58:22 +0300] Full reload complete.
E [02/May/2007:22:58:22 +0300] Unable to bind socket for address ::1:631 - 
Address already in use.
E [02/May/2007:22:58:22 +0300] Unable to bind socket for address 
127.0.0.1:631 - Address already in use.
I [02/May/2007:22:58:22 +0300] Listening to /var/run/cups.sock on fd 2...
E [02/May/2007:22:58:22 +0300] cupsdStartBrowsing: Unable to bind 
broadcast socket - Address already in use.
I [02/May/2007:22:58:48 +0300] commptr="list+1+0+requested-attributes=all"
I [02/May/2007:22:58:48 +0300] Started 
"/usr/local/libexec/cups/daemon/cups-driverd" (pid=89822)
E [02/May/2007:22:58:48 +0300] [cups-driverd] Unable to open PPD directory 
"/usr/local/share/cups/model": Permission denied
I [02/May/2007:22:59:38 +0300] commptr="list+1+0+requested-attributes=all"
I [02/May/2007:22:59:38 +0300] Started 
"/usr/local/libexec/cups/daemon/cups-driverd" (pid=89823)
E [02/May/2007:22:59:38 +0300] [cups-driverd] Unable to open PPD directory 
"/usr/local/share/cups/model": Permission denied
I [02/May/2007:22:59:52 +0300] commptr="list+1+0+requested-attributes=all"
I [02/May/2007:22:59:52 +0300] Started 
"/usr/local/libexec/cups/daemon/cups-driverd" (pid=89824)
E [02/May/2007:22:59:52 +0300] [cups-driverd] Unable to open PPD directory 
"/usr/local/share/cups/model": Permission denied

I tried commenting out all security and authorization settings in the conf 
file, but it did not help.  I compared the settings on the files and 
folders listed in the log file to another machine that is working with 
cups and they all seem correct.  Not sure what to try now, any help would be 
really appreciated.  Please let me know if there is any more debug info 
needed.

TIA



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20070502201724.O88357>