Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 03 Oct 2011 11:04:21 -0400
From:      rvclayton@verizon.net (R. Clayton)
To:        freebsd-questions@freebsd.org
Subject:   p11-kit port patch fail on 8.2p3.
Message-ID:  <87d3ee5d6y.fsf@UlanBator.myhome.westell.com>

Next in thread | Raw E-Mail | Index | Archive | Help
I am running

  # uname -a 
  FreeBSD AddisAbaba 8.2-RELEASE-p3 FreeBSD 8.2-RELEASE-p3 #0: 
  Tue Sep 27 18:07:27 UTC 2011
  root@i386-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  i386

  # 

After updating the ports tree with "portsnap fetch update", I ran pkgdb to get

  # pkgdb -F
  --->  Checking the package registry database
  Stale dependency: gnutls-2.12.11 -> p11-kit-0.6 (security/p11-kit):
  Install stale dependency? ([y]es/[n]o/[a]ll) [yes] 
  [Gathering depends for security/p11-kit . done]
  --->  Installing 'p11-kit-0.7' from a port (security/p11-kit)
  --->  Building '/usr/ports/security/p11-kit'
  ===>  Cleaning for p11-kit-0.7
  ===>  License check disabled, port has not defined LICENSE
  ===>  Extracting for p11-kit-0.7
  => SHA256 Checksum OK for p11-kit-0.7.tar.gz.
  ===>  Patching for p11-kit-0.7
  ===>   p11-kit-0.7 depends on package: libtool>=2.4 - found
  ===>  Applying FreeBSD patches for p11-kit-0.7
  Ignoring previously applied (or reversed) patch.
  1 out of 1 hunks ignored--saving rejects to p11-kit/modules.c.rej
  => Patch patch-p11-kit-modules.c failed to apply cleanly.
  *** Error code 1

  Stop in /usr/ports/security/p11-kit.
  ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portinstall20111003-41254-165xny4-0 env make
  ** Fix the problem and try again.
  ** Listing the failed packages (-:ignored / *:skipped / !:failed)
          ! security/p11-kit      (patch error)
  Command failed [exit code 1]: /usr/local/sbin/portinstall security/p11-kit

  # 

I poked around a bit

  # grep -i p11 /usr/ports/UPDATING 

  #

and tried a few things involving manually fiddling with files, but couldn't
trick the system into completing the upgrade.  Looking through
gmane.os.freebsd.* and other places didn't turn up anything that looked like it
would help.

How do I get p11-kit to upgrade?






Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?87d3ee5d6y.fsf>