Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 20 Sep 2009 09:45:35 -0700
From:      Joseph Olatt <joji@eskimo.com>
To:        "N. Raghavendra" <raghu@mri.ernet.in>
Cc:        FreeBSD Question <questions@freebsd.org>
Subject:   Re: Unable to use CD/DVD drive
Message-ID:  <20090920164535.GA24904@shell.eskimo.com>
In-Reply-To: <86zl8q1c67.fsf@riemann.mri.ernet.in>
References:  <86zl8q1c67.fsf@riemann.mri.ernet.in>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sun, Sep 20, 2009 at 09:48:40AM +0530, N. Raghavendra wrote:
> Until a couple of months ago, I was able to read and write CDs and
> DVDs.  Since then, I haven't been able to do so.  When I try to mount
> a CD/DVD, the process just hangs without the media being mounted, or I
> get errors like this:
> 
> [root@griffin:/root]# mount /cdrom
> mount_cd9660: /dev/acd0: Input/output error
> 
> Also, `/var/log/messages' shows lines like
> 
> Sep 20 09:11:51 griffin kernel: g_vfs_done():acd0[READ(offset=32768, length=2048)]error = 5
> 
> Similar messages occur when I try to write a CD/DVD using cdrecord(1).
> The CD/DVD drive is a `<PBDS DVD+-RW DH-16W1S 2D14> Removable CD-ROM
> SCSI-0 device'.  I upgraded my kernel to no avail.
> 
> More details are below.  Any help is appreciated.
> 
> Thanks and regards,
> Raghavendra.
> 
> ----------------------------------------------------------------------
> 
> 1. Output of dmesg: attached.
> 
> 2. Kernel configuration file
> ----------------------------
> 
> include "GENERIC"
> ident GRIFFIN
> device atapicam
> device sound
> device snd_hda
> options ACCEPT_FILTER_HTTP
> 
> 3. /boot/loader.conf
> --------------------
> 
> nvidia_load="YES"
> hw.ata.ata_dma="1"
> 
> 4. /etc/fstab
> -------------
> 
> # Device    Mountpoint FStype  Options   Dump Pass#
> /dev/ad4s3b none       swap    sw        0    0
> /dev/ad4s3a /          ufs     rw        1    1
> /dev/ad4s3f /home      ufs     rw        2    2
> /dev/ad4s3e /opt       ufs     rw        2    2
> /dev/ad4s3h /tmp       ufs     rw        2    2
> /dev/ad4s3d /usr       ufs     rw        2    2
> /dev/ad4s3g /var       ufs     rw        2    2
> /dev/acd0   /cdrom     cd9660  ro,noauto 0    0
> 
> 5. Output of `cdrecord --scanbus'
> --------------------------------
> 
> [root@griffin:/root]# cdrecord -scanbus
> Cdrecord-Clone 2.01 (i386-unknown-freebsd7.0) Copyright (C) 1995-2004 Jorg Schilling
> Using libscg version 'schily-0.8'.
> scsibus0:
>         0,0,0     0) 'TEAC    ' 'USB   HS-CF Card' '4.08' Removable
>         Disk
>         0,1,0     1) *
>         0,2,0     2) *
>         0,3,0     3) *
>         0,4,0     4) *
>         0,5,0     5) *
>         0,6,0     6) *
>         0,7,0     7) *
> scsibus4:
>         4,0,0   400) 'PBDS    ' 'DVD+-RW DH-16W1S' '2D14' Removable
>         CD-ROM
>         4,1,0   401) *
>         4,2,0   402) *
>         4,3,0   403) *
>         4,4,0   404) *
>         4,5,0   405) *
>         4,6,0   406) *
>         4,7,0   407) *
> 
> -- 
> N. Raghavendra <raghu@mri.ernet.in> | http://www.retrotexts.net/
> Harish-Chandra Research Institute   | http://www.mri.ernet.in/
> See message headers for contact and OpenPGP information.
> 
> 

> Copyright (c) 1992-2009 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
> 	The Regents of the University of California. All rights reserved.
> FreeBSD is a registered trademark of The FreeBSD Foundation.
> FreeBSD 7.2-STABLE #3: Thu Sep 10 21:00:51 IST 2009
>     root@griffin.campus.hri:/usr/obj/usr/src/sys/GRIFFIN
> Timecounter "i8254" frequency 1193182 Hz quality 0
> CPU: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz (2394.01-MHz 686-class CPU)
>   Origin = "GenuineIntel"  Id = 0x6fb  Stepping = 11
>   Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
>   Features2=0xe3bd<SSE3,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM>
>   AMD Features=0x20100000<NX,LM>
>   AMD Features2=0x1<LAHF>
>   Cores per package: 4
> real memory  = 3219718144 (3070 MB)
> avail memory = 3136708608 (2991 MB)
> ACPI APIC Table: <DELL   FX09   >
> FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
>  cpu0 (BSP): APIC ID:  0
>  cpu1 (AP): APIC ID:  1
>  cpu2 (AP): APIC ID:  2
>  cpu3 (AP): APIC ID:  3
> ioapic0: Changing APIC ID to 4
> ioapic0 <Version 2.0> irqs 0-23 on motherboard
> kbd1 at kbdmux0
> acpi0: <DELL FX09   > on motherboard
> acpi0: [ITHREAD]
> acpi0: Power Button (fixed)
> acpi0: reservation of 0, a0000 (3) failed
> acpi0: reservation of 100000, bfd90000 (3) failed
> Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
> acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
> acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
> device_attach: acpi_hpet0 attach returned 12
> acpi_button0: <Power Button> on acpi0
> pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
> pci0: <ACPI PCI bus> on pcib0
> pcib1: <PCI-PCI bridge> irq 16 at device 1.0 on pci0
> pci1: <PCI bus> on pcib1
> vgapci0: <VGA-compatible display> port 0xcf00-0xcf7f mem 0xfa000000-0xfaffffff,0xd0000000-0xdfffffff,0xf8000000-0xf9ffffff irq 16 at device 0.0 on pci1
> nvidia0: <GeForce 8600 GT> on vgapci0
> vgapci0: child nvidia0 requested pci_enable_busmaster
> vgapci0: child nvidia0 requested pci_enable_io
> nvidia0: [GIANT-LOCKED]
> nvidia0: [ITHREAD]
> em0: <Intel(R) PRO/1000 Network Connection 6.9.6> port 0xff00-0xff1f mem 0xfdfc0000-0xfdfdffff,0xfdfff000-0xfdffffff irq 20 at device 25.0 on pci0
> em0: Using MSI interrupt
> em0: [FILTER]
> em0: Ethernet address: 00:1d:09:99:b5:ee
> uhci0: <UHCI (generic) USB controller> port 0xfe00-0xfe1f irq 16 at device 26.0 on pci0
> uhci0: [GIANT-LOCKED]
> uhci0: [ITHREAD]
> usb0: <UHCI (generic) USB controller> on uhci0
> usb0: USB revision 1.0
> uhub0: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
> uhub0: 2 ports with 2 removable, self powered
> uhci1: <UHCI (generic) USB controller> port 0xfd00-0xfd1f irq 21 at device 26.1 on pci0
> uhci1: [GIANT-LOCKED]
> uhci1: [ITHREAD]
> usb1: <UHCI (generic) USB controller> on uhci1
> usb1: USB revision 1.0
> uhub1: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
> uhub1: 2 ports with 2 removable, self powered
> uhci2: <UHCI (generic) USB controller> port 0xfc00-0xfc1f irq 19 at device 26.2 on pci0
> uhci2: [GIANT-LOCKED]
> uhci2: [ITHREAD]
> usb2: <UHCI (generic) USB controller> on uhci2
> usb2: USB revision 1.0
> uhub2: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
> uhub2: 2 ports with 2 removable, self powered
> ehci0: <EHCI (generic) USB 2.0 controller> mem 0xfdffe000-0xfdffe3ff irq 18 at device 26.7 on pci0
> ehci0: [GIANT-LOCKED]
> ehci0: [ITHREAD]
> usb3: EHCI version 1.0
> usb3: companion controllers, 2 ports each: usb0 usb1 usb2
> usb3: <EHCI (generic) USB 2.0 controller> on ehci0
> usb3: USB revision 2.0
> uhub3: <Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb3
> uhub3: 6 ports with 6 removable, self powered
> hdac0: <Intel 82801I High Definition Audio Controller> mem 0xfdff4000-0xfdff7fff irq 22 at device 27.0 on pci0
> hdac0: HDA Driver Revision: 20090624_0136
> hdac0: [ITHREAD]
> uhci3: <UHCI (generic) USB controller> port 0xfb00-0xfb1f irq 23 at device 29.0 on pci0
> uhci3: [GIANT-LOCKED]
> uhci3: [ITHREAD]
> usb4: <UHCI (generic) USB controller> on uhci3
> usb4: USB revision 1.0
> uhub4: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb4
> uhub4: 2 ports with 2 removable, self powered
> uhci4: <UHCI (generic) USB controller> port 0xfa00-0xfa1f irq 19 at device 29.1 on pci0
> uhci4: [GIANT-LOCKED]
> uhci4: [ITHREAD]
> usb5: <UHCI (generic) USB controller> on uhci4
> usb5: USB revision 1.0
> uhub5: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb5
> uhub5: 2 ports with 2 removable, self powered
> uhci5: <UHCI (generic) USB controller> port 0xf900-0xf91f irq 18 at device 29.2 on pci0
> uhci5: [GIANT-LOCKED]
> uhci5: [ITHREAD]
> usb6: <UHCI (generic) USB controller> on uhci5
> usb6: USB revision 1.0
> uhub6: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb6
> uhub6: 2 ports with 2 removable, self powered
> ehci1: <EHCI (generic) USB 2.0 controller> mem 0xfdffd000-0xfdffd3ff irq 23 at device 29.7 on pci0
> ehci1: [GIANT-LOCKED]
> ehci1: [ITHREAD]
> usb7: EHCI version 1.0
> usb7: companion controllers, 2 ports each: usb4 usb5 usb6
> usb7: <EHCI (generic) USB 2.0 controller> on ehci1
> usb7: USB revision 2.0
> uhub7: <Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb7
> uhub7: 6 ports with 6 removable, self powered
> umass0: <TEAC CA-200, class 0/0, rev 2.00/4.08, addr 2> on uhub7
> pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
> pci2: <ACPI PCI bus> on pcib2
> isab0: <PCI-ISA bridge> at device 31.0 on pci0
> isa0: <ISA bus> on isab0
> atapci0: <Intel ICH9 SATA300 controller> port 0xf800-0xf807,0xf700-0xf703,0xf600-0xf607,0xf500-0xf503,0xf400-0xf40f,0xf300-0xf30f irq 19 at device 31.2 on pci0
> atapci0: [ITHREAD]
> ata2: <ATA channel 0> on atapci0
> ata2: [ITHREAD]
> ata3: <ATA channel 1> on atapci0
> ata3: [ITHREAD]
> pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
> atapci1: <Intel ICH9 SATA300 controller> port 0xf100-0xf107,0xf000-0xf003,0xef00-0xef07,0xee00-0xee03,0xed00-0xed0f,0xec00-0xec0f irq 19 at device 31.5 on pci0
> atapci1: [ITHREAD]
> ata4: <ATA channel 0> on atapci1
> ata4: [ITHREAD]
> ata5: <ATA channel 1> on atapci1
> ata5: [ITHREAD]
> acpi_tz0: <Thermal Zone> on acpi0
> fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
> fdc0: [FILTER]
> cpu0: <ACPI CPU> on acpi0
> est0: <Enhanced SpeedStep Frequency Control> on cpu0
> est: CPU supports Enhanced Speedstep, but is not recognized.
> est: cpu_vendor GenuineIntel, msr 927092706000927
> device_attach: est0 attach returned 6
> p4tcc0: <CPU Frequency Thermal Control> on cpu0
> cpu1: <ACPI CPU> on acpi0
> est1: <Enhanced SpeedStep Frequency Control> on cpu1
> est: CPU supports Enhanced Speedstep, but is not recognized.
> est: cpu_vendor GenuineIntel, msr 927092706000927
> device_attach: est1 attach returned 6
> p4tcc1: <CPU Frequency Thermal Control> on cpu1
> cpu2: <ACPI CPU> on acpi0
> est2: <Enhanced SpeedStep Frequency Control> on cpu2
> est: CPU supports Enhanced Speedstep, but is not recognized.
> est: cpu_vendor GenuineIntel, msr 927092706000927
> device_attach: est2 attach returned 6
> p4tcc2: <CPU Frequency Thermal Control> on cpu2
> cpu3: <ACPI CPU> on acpi0
> est3: <Enhanced SpeedStep Frequency Control> on cpu3
> est: CPU supports Enhanced Speedstep, but is not recognized.
> est: cpu_vendor GenuineIntel, msr 927092706000927
> device_attach: est3 attach returned 6
> p4tcc3: <CPU Frequency Thermal Control> on cpu3
> acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
> device_attach: acpi_hpet0 attach returned 12
> pmtimer0 on isa0
> ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
> ata0: [ITHREAD]
> ata1 at port 0x170-0x177,0x376 irq 15 on isa0
> ata1: [ITHREAD]
> atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
> atkbd0: <AT Keyboard> irq 1 on atkbdc0
> kbd0 at atkbd0
> atkbd0: [GIANT-LOCKED]
> atkbd0: [ITHREAD]
> ppc0: parallel port not found.
> sc0: <System console> at flags 0x100 on isa0
> sc0: VGA <16 virtual consoles, flags=0x300>
> sio0: configured irq 4 not in bitmap of probed irqs 0
> sio0: port may not be enabled
> sio0: configured irq 4 not in bitmap of probed irqs 0
> sio0: port may not be enabled
> sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
> sio0: type 8250 or not responding
> sio0: [FILTER]
> sio1: configured irq 3 not in bitmap of probed irqs 0
> sio1: port may not be enabled
> vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
> uhub8: <Dell Dell USB Keyboard Hub, class 9/0, rev 1.10/48.01, addr 2> on uhub2
> uhub8: 3 ports with 2 removable, bus powered
> ukbd0: <Dell Dell USB Keyboard Hub, class 0/0, rev 1.10/48.00, addr 3> on uhub8
> kbd2 at ukbd0
> uhid0: <Dell Dell USB Keyboard Hub, class 0/0, rev 1.10/48.00, addr 3> on uhub8
> Timecounters tick every 1.000 msec
> ad4: 305245MB <Seagate ST3320620AS 3.ADG> at ata2-master SATA300
> (probe0:umass-sim0:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0 
> (probe0:umass-sim0:0:0:0): CAM Status: SCSI Status Error
> (probe0:umass-sim0:0:0:0): SCSI Status: Check Condition
> (probe0:umass-sim0:0:0:0): NOT READY asc:3a,0
> (probe0:umass-sim0:0:0:0): Medium not present
> (probe0:umass-sim0:0:0:0): Unretryable error
> (probe0:umass-sim0:0:0:1): TEST UNIT READY. CDB: 0 20 0 0 0 0 
> (probe0:umass-sim0:0:0:1): CAM Status: SCSI Status Error
> (probe0:umass-sim0:0:0:1): SCSI Status: Check Condition
> (probe0:umass-sim0:0:0:1): NOT READY asc:3a,0
> (probe0:umass-sim0:0:0:1): Medium not present
> (probe0:umass-sim0:0:0:1): Unretryable error
> (probe0:umass-sim0:0:0:2): TEST UNIT READY. CDB: 0 40 0 0 0 0 
> (probe0:umass-sim0:0:0:2): CAM Status: SCSI Status Error
> (probe0:umass-sim0:0:0:2): SCSI Status: Check Condition
> (probe0:umass-sim0:0:0:2): NOT READY asc:3a,0
> (probe0:umass-sim0:0:0:2): Medium not present
> (probe0:umass-sim0:0:0:2): Unretryable error
> (probe0:umass-sim0:0:0:3): TEST UNIT READY. CDB: 0 60 0 0 0 0 
> (probe0:umass-sim0:0:0:3): CAM Status: SCSI Status Error
> (probe0:umass-sim0:0:0:3): SCSI Status: Check Condition
> (probe0:umass-sim0:0:0:3): NOT READY asc:3a,0
> (probe0:umass-sim0:0:0:3): Medium not present
> (probe0:umass-sim0:0:0:3): Unretryable error
> da0 at umass-sim0 bus 0 target 0 lun 0
> da0: <TEAC USB   HS-CF Card 4.08> Removable Direct Access SCSI-0 device 
> da0: 40.000MB/s transfers
> da0: Attempt to query device size failed: NOT READY, Medium not present
> da1 at umass-sim0 bus 0 target 0 lun 1
> da1: <TEAC USB   HS-xD/SM 4.08> Removable Direct Access SCSI-0 device 
> da1: 40.000MB/s transfers
> da1: Attempt to query device size failed: NOT READY, Medium not present
> da2 at umass-sim0 bus 0 target 0 lun 2
> da2: <TEAC USB   HS-MS Card 4.08> Removable Direct Access SCSI-0 device 
> da2: 40.000MB/s transfers
> da2: Attempt to query device size failed: NOT READY, Medium not present
> da3 at umass-sim0 bus 0 target 0 lun 3
> da3: <TEAC USB   HS-SD Card 4.08> Removable Direct Access SCSI-0 device 
> da3: 40.000MB/s transfers
> da3: Attempt to query device size failed: NOT READY, Medium not present
> acd0: DVDR <PBDS DVD+/-RW DH-16W1S/2D14> at ata3-master SATA150
> hdac0: HDA Codec #2: Realtek ALC888
> pcm0: <HDA Realtek ALC888 PCM #0 Analog> at cad 2 nid 1 on hdac0
> pcm1: <HDA Realtek ALC888 PCM #1 Analog> at cad 2 nid 1 on hdac0
> SMP: AP CPU #1 Launched!
> SMP: AP CPU #2 Launched!
> SMP: AP CPU #3 Launched!
> acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00 
> Trying to mount root from ufs:/dev/ad4s3a
> WARNING: / was not properly dismounted
> (probe0:ata3:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0 
> (probe0:ata3:0:0:0): CAM Status: SCSI Status Error
> (probe0:ata3:0:0:0): SCSI Status: Check Condition
> (probe0:ata3:0:0:0): NOT READY asc:3a,0
> (probe0:ata3:0:0:0): Medium not present
> (probe0:ata3:0:0:0): Unretryable error
> cd0 at ata3 bus 0 target 0 lun 0
> cd0: <PBDS DVD+-RW DH-16W1S 2D14> Removable CD-ROM SCSI-0 device 
> cd0: 3.300MB/s transfers
> cd0: Attempt to query device size failed: NOT READY, Medium not present
> WARNING: /home was not properly dismounted
> WARNING: /opt was not properly dismounted
> WARNING: /tmp was not properly dismounted
> WARNING: /usr was not properly dismounted
> WARNING: /var was not properly dismounted
> ums0: <vendor 0x0461 USB Optical Mouse, class 0/0, rev 2.00/2.00, addr 4> on uhub2
> ums0: 3 buttons and Z dir.
> em0: link state changed to DOWN
> em0: link state changed to UP
> em0: link state changed to DOWN
> em0: link state changed to UP
> em0: link state changed to DOWN
> em0: link state changed to UP
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> em0: link state changed to DOWN
> em0: link state changed to UP
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> arp: unknown hardware address format (0x0000)
> em0: link state changed to DOWN
> em0: link state changed to UP
> g_vfs_done():acd0[READ(offset=32768, length=2048)]error = 5

> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"


Just to rule out hardware problems with your CD/DVD drive, you might
want to put in a live CD of Ubuntu (or PCBSD) and see if your CD/DVD
drive works fine. 




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20090920164535.GA24904>