Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 28 Jan 2011 00:25:51 +0100 (CET)
From:      Gerald Pfeifer <gerald@pfeifer.com>
To:        Rob Farmer <rfarmer@predatorlabs.net>,  Zbigniew Komarnicki <cblasius@gmail.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Can't install - Octave, SuiteSparse
Message-ID:  <alpine.LNX.2.00.1101280023000.7158@gerinyyl.fvgr>
In-Reply-To: <201010271215.48697.cblasius@gmail.com>
References:  <201010271009.13356.cblasius@gmail.com> <AANLkTinThd2JwQsZ=whw+0g=xCyz9E9zFJsYAqAg4kZO@mail.gmail.com> <201010271215.48697.cblasius@gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Wed, 27 Oct 2010, Zbigniew Komarnicki wrote:
>> This is probably a GCC problem. What exact version are you using
>> (pkg_info | grep gcc)? There is another recent report of issues with
>> the latest update to lang/gcc45:
>>
>> http://lists.freebsd.org/pipermail/freebsd-ports/2010-October/064212.html
>>
>> Perhaps the maintainer knows more (cc'd) or you could try rolling back
>> temporarily - I've successfully built suitesparse with 4.5.2.20101014
>> on amd64 current recently.
> # pkg_info | grep gcc
> gcc-4.4.6.20101012  GNU Compiler Collection 4.4
> gcc-4.5.2.20101021  GNU Compiler Collection 4.5
> gccmakedep-1.0.2    Create dependencies in makefiles using 'gcc -M'

Sorry, I just realized I totally missed this question.  Are you
still seeing the problem?

Looking at the web archive of this thread, I do not see anything
stand out.  What happens if you remove gcc-4.4.6.20101012 and try
to build everything with GCC 4.5?  

It may be worthwhile doing a 'portupgrade -a' or similar and rebuild
all ports with one and the same compiler before trying again.

Gerald



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.LNX.2.00.1101280023000.7158>