Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 3 Mar 2006 12:22:31 -0500
From:      Kris Kennaway <kris@obsecurity.org>
To:        Bill Milford <freebsd@milfordmail.com>
Cc:        freebsd-stable@FreeBSD.ORG
Subject:   Re: configure scripts ignores parameters
Message-ID:  <20060303172231.GA8478@xor.obsecurity.org>
In-Reply-To: <!&!AAAAAAAAAAAYAAAAAAAAAE09+/5QgBZBvgbigfttNszCgAAAEAAAAO0bkCUWkdpEgDk8P5dU4/YBAAAAAA==@milfordmail.com>
References:  <20060303112026.GA10522@mid.pc5.i.0x5.de> <!&!AAAAAAAAAAAYAAAAAAAAAE09+/5QgBZBvgbigfttNszCgAAAEAAAAO0bkCUWkdpEgDk8P5dU4/YBAAAAAA==@milfordmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

--nFreZHaLTZJo0R7j
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Fri, Mar 03, 2006 at 09:44:17AM -0600, Bill Milford wrote:
> > -----Original Message-----
> > From: owner-freebsd-stable@freebsd.org [mailto:owner-freebsd-stable@fre=
ebsd.org] On Behalf Of
> > Nicolas Rachinsky
> > Sent: Friday, March 03, 2006 5:20 AM
> > To: freebsd-stable@FreeBSD.ORG
> > Subject: Re: configure scripts ignores parameters
> >=20
> > * "Elisey O. Savateev" <b3k@mail.ru> [2006-03-03 16:10 +0500]:
> > > Fri, 3 Mar 2006 11:56:09 +0100
> > > Nicolas Rachinsky <fbsd-stable-0@ml.turing-complete.org> wrote:
> > >
> > > >
> > > > Do you have shells/bash (bash-3.1.10) installed?
> > > >
> > >
> > > 	Yes. I have.
> >=20
> >=20
> > I had one problem here, but unfortunately not the time to really look
> > at it (and I don't have time to try it again).
> >=20
> > My bash3 here did not correctly process
> > | for foo
> > | do echo "$foo"
> > | done
> > A similar contruct seems to be in some (most, all?) configure scripts,
> > which automatically use bash to be executed (if it's available).
> >=20
> > I installed shells/bash2 (bash-2.05b.007_4) and my problem
> > disappeared.
> >=20
> > HTH,
> > Nicolas
> >=20
> > --
> > http://www.rachinsky.de/nicolas
> [Bill Milford]=20
> I am having the some problem.  My temporary fix is to either install bash=
-3.0.16_1 which is the
> latest bash package available or you can set CONFIG_SHELL=3D/bin/sh in yo=
ur environment. =20
> The configure scripts will use bash if available and when it re-executes =
itself, somehow the
> command line options do not get passed correctly.  Even the most simple o=
ption: ./configure --help
> fails.  It was causing the previously reported issues with the apr-db4 po=
rt.  It causes problems
> for me in the OpenCA configure script.  I suspect that it will affect man=
y ports that use
> ./configure scripts to pass parameters.  I am going to re build all of my=
 ports when this is
> finally resolved.

I hope someone has reported this error to the bash developers.

Kris

--nFreZHaLTZJo0R7j
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.1 (FreeBSD)

iD8DBQFECHtXWry0BWjoQKURAjlDAKDwyr2YyRGunYOTkZcWbMRKNdtCgQCg1FRj
hCL9GtytdYg+PpXLOa8lq9g=
=y6AL
-----END PGP SIGNATURE-----

--nFreZHaLTZJo0R7j--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20060303172231.GA8478>