Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 3 Dec 2015 01:27:44 +0100 (CET)
From:      Gerald Pfeifer <gerald@pfeifer.com>
To:        Dimitry Andric <dim@FreeBSD.org>
Cc:        "William A. Mahaffey III" <wam@hiwaay.net>, freebsd-questions@freebsd.org,  freebsd-toolchain@freebsd.org
Subject:   Re: gcc5 question
Message-ID:  <alpine.LSU.2.20.1512030125540.3929@anthias>
In-Reply-To: <95C3DA2C-639B-453D-8EC7-B92A6A1A728B@FreeBSD.org>
References:  <565F8881.8010705@hiwaay.net> <95C3DA2C-639B-453D-8EC7-B92A6A1A728B@FreeBSD.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Thu, 3 Dec 2015, Dimitry Andric wrote:
>> I just did a pkg-upgrade of gcc5, & upgraded the port as well. I noticed that a 'make showconfig' in the port now shows Graphite support enabled by default. However, a 'gcc -v --help' on the pkg installed version shows no libisl, req'd for Graphite support (I think). Is the pkg built differently from the port ? TIA & have a good one.
> I've tried building the port with the GRAPHITE option enabled, but it
> died with various compilation errors about missing isl types, even while
> isl was installed.  So I'm not sure about the state of this support. :-)
> 
> Gerald, any idea?  I suppose the option is expected to work?

If you have an up-to-date lang/gcc5 port, you should not be 
able to specify GRAPHITE any longer.

Somehow my testing must have been flawed (even though I recall it 
explicitly tested, so perhaps a typo when specifying the option) 
and this will be fixed when updating to GCC 5.3, hopefully in the 
next few days.

Give lang/gcc5-devel a try, which is close to what GCC 5.3 is
going to be.  That one should work.  I tested it again yesterday,
just to be sure.

Gerald



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.LSU.2.20.1512030125540.3929>