Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 22 Nov 2006 18:16:21 -0500
From:      "Tamouh H." <hakmi@rogers.com>
To:        "'Toomas Aas'" <toomas.aas@raad.tartu.ee>, <questions@freebsd.org>
Subject:   RE: ICH7 SATA RAID (LSI MegaRAID) 
Message-ID:  <20061122231758.D87AE43D55@mx1.FreeBSD.org>
In-Reply-To: <4564D667.4000507@raad.tartu.ee>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
=20
>=20
> Hello!
>=20
> I've bought a small server with Intel SE7230NH1 motherboard,=20
> which incorporates the ICH7 SATA RAID controller. Using the=20
> LSI BIOS utility, I created a RAID1 array of two disks and=20
> installed FreeBSD 6.2-RC1
> (amd64) on it.
>=20
> atapci1: <Intel ICH7 SATA300 controller> port=20
> 0x30c8-0x30cf,0x30e4-0x30e7,0x30c0-0x30c7,0x30e0-0x30e3,0x30a0-0x30af
> mem 0x88200000-0x882003ff irq 19 at device 31.2 on pci0
> atapci1: AHCI Version 01.10 controller with 4 ports detected
> ata2: <ATA channel 0> on atapci1
> ata3: <ATA channel 1> on atapci1
> ata4: <ATA channel 2> on atapci1
> ata5: <ATA channel 3> on atapci1
> ad4: 476940MB <Seagate ST3500630AS 3.AAE> at ata2-master SATA300
> ad6: 476940MB <Seagate ST3500630AS 3.AAE> at ata3-master SATA300
> ar0: 476772MB <LSILogic v3 MegaRAID RAID1> status: READY
> ar0: disk0 READY (master) using ad4 at ata2-master
> ar0: disk1 READY (mirror) using ad6 at ata3-master
>=20
> This server has a hot-swap drive cage that allows you to=20
> power off individual drives. I simulated a drive failure by=20
> powering off one of the drives. This resulted in console message:
>=20
> ar0: warning: mirror protection lost. RAID1 array in DEGRADED mode.
> ar0: writing of LSILogic v3 MegaRAID metadata is NOT supported yet.
> subdisk6: detached
> ad6: detached
>=20
> OK, the disk went away. This is witnessed by atacontrol:
> # atacontrol status ar0
> ar0: ATA RAID1 subdisks: ad4 DOWN status DEGRADED
>=20
> Now, I power the disk on again. This brings on the following=20
> console message.
>=20
> ad6: 476940MB <Seagate ST3500630AS 3.AAE> at ata3-master SATA300
>=20
> The array status is still degraded, as shown by atacontrol:
> #atacontrol status ar0
> ar0: ATA RAID1 subdisks: ad4 ad6 status: DEGRADED
>=20
> OK, so I think I need to rebuild the array, but this doesn't succeed:
> #atacontrol rebuild ar0
> IOCATARAIDREBUILD: Input/Output error.
>=20
> When I reboot the server, it comes back up with the array at=20
> READY status immediately. Maybe this is because I have "Auto=20
> rebuild" set to "Yes" in BIOS. But is there any way to=20
> recover from this kind of failure without rebooting? Are my=20
> problems caused merely by the fact that "writing of LSILogic=20
> v3 MegaRAID metadata is NOT supported yet", or am I doing=20
> something wrong? Or maybe this is the problem that exists only in
> amd64 version and not in i386?
>=20
> Thanks in advance,
> --
> Toomas
>=20

>From experience, with these Software RAID, once you remove a disk, =
you'll have to format it before you put the disk back in. Otherwise, =
this will cause problems as the SW RAID will read the RAID part from the =
disk and think it is working properly.

Do your test by removing the Disk, then format it completely, insert it =
back. Or plug a new HDD in its place.

Tamouh





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20061122231758.D87AE43D55>