Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 26 Jul 2007 12:18:52 -0400
From:      John Nielsen <lists@jnielsen.net>
To:        freebsd-questions@freebsd.org
Subject:   RALUS for Linux - authentication failing
Message-ID:  <200707261218.52377.lists@jnielsen.net>

Next in thread | Raw E-Mail | Index | Archive | Help
I'm trying to get the latest Linux remote agent for Backup Exec to run on a 
FreeBSD-amd64 machine. The exact version is RALUS-11d.7170.2, although I 
suspect any 10.0 - 11d version would be the same.

After trying a few things (including installing on a real Linux host) I was 
able to identify and extract the files containing the two rpm's that are 
actually installed. I ran those through rpm2cpio and got a simple directory 
layout. I duplicated the directory structure and config file from the Linux 
host and ran the main executable. (The init script tries (and fails, even 
after I fixed all the hardcoded paths) to do some housekeeping, but none of 
it is necessary for the thing to actually run.)

The executable seems to run okay and the host even shows up as a Unix target 
on the (Windows) Backup Exec server, but I'm unable to authenticate, 
preventing me from doing any backups. I've used the agent on other Linux and 
Solaris hosts successfully, and it generally just takes the OS root (or other 
user in the beoper group) password, without a need to set any ralus-specific 
passwords anywhere.

Has anyone else gotten this to work on FreeBSD? If not, can anyone tell me (or 
speculate) what method the agent uses / might use to authenticate users?

I was able to enable logging, so I know it sees the login attempt but it can't 
verify the password:

18006 Thu Jul 26 11:51:16 2007 : LogonUser failed for user: root because 
LogonUser: The input password does not match the OS password


Thanks for any input (well, anything other than "don't do that" :) ).

JN



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200707261218.52377.lists>