Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 30 Nov 2012 12:18:11 -0600
From:      Adam Vande More <amvandemore@gmail.com>
To:        Tim Daneliuk <tundra@tundraware.com>
Cc:        FreeBSD Mailing List <freebsd-questions@freebsd.org>
Subject:   Re: No xrstor Error Encountered During Buildkernel
Message-ID:  <CA+tpaK1c7XgCMUsmKDdGhFtvx7j8y1SD6tHHG=x17xr1ih7vCQ@mail.gmail.com>
In-Reply-To: <50B8F4BB.9020806@tundraware.com>
References:  <50B8F4BB.9020806@tundraware.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, Nov 30, 2012 at 12:02 PM, Tim Daneliuk <tundra@tundraware.com>wrote:

> I have a FBSD 9.0 VM running under VirtualBox (hosted under Mint Linux).
> I blew away /usr/src and rebuilt it with 9-STABLE via subversion.
> Then, I did a mergemaster.
>
> When I try to now do a buildword, it blows up after about 15 minutes
> of compilation with:
>
> /usr/src/sys/amd64/acpica/**acpi_switch.S: Assembler messages:
> /usr/src/sys/amd64/acpica/**acpi_switch.S:146: Error: no such
> instruction: `xsetbv
> '
> /usr/src/sys/amd64/acpica/**acpi_switch.S:147: Error: no such
> instruction: `xrstor
>  (%rbx)'
> *** [acpi_switch.o] Error code 1
>
> Stop in /usr/obj/usr/src/sys/GENERIC.
> *** [buildkernel] Error code 1
>
>
> Ideas?


That is a VM is not related to your problem.  Your problem lies somewhere
within the environment in the OS like an incorrect make.conf or ccache
usage. Occasionally, a problem on a STABLE branch preventing a build, but
this is rare.



-- 
Adam Vande More



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CA+tpaK1c7XgCMUsmKDdGhFtvx7j8y1SD6tHHG=x17xr1ih7vCQ>