Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 15 Jan 2010 16:17:22 +0000
From:      Paul B Mahol <onemda@gmail.com>
To:        Christoph Kukulies <kuku@kukulies.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: rum0 acting as an Access point (belkin router) 8.0 R
Message-ID:  <3a142e751001150817x7b4da53fs16cebd2e097890b4@mail.gmail.com>
In-Reply-To: <4B507B9A.3050803@kukulies.org>
References:  <4B507B9A.3050803@kukulies.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 1/15/10, Christoph Kukulies <kuku@kukulies.org> wrote:
> I'm not sure wether syntax has changed but I wanted to cretae an wlan
> acess point
> and tried various things. Under 7.0 I got it working with the following
> command
>
> ifconfig rum0 inet 10.0.0.1/24 mediaopt hostap ssid CITYOFFICE  wepmode
> on wepkey 0xf00baf00ba weptxkey 1 channel 1
>
>
> I tried this but got a socket error "Invalid argument".
>
> Then I tried (from an example in the rum (4) manpage):ifconfig wlan
> create wlandev rum0 10.0.0.1/24 mediaopt hostap CITYOFFICE wepmode on
> wepkey 0xf00baaf00baa  weptxkey 1 channel 1
>

Perhaps you want this one:

ifconfig wlan create wlandev rum0 10.0.0.1/24 wlanmode hostap ssid
CITYOFFICE wepmode on wepkey 0xf00baaf00baa  weptxkey 1 channel 1

> and got:
>
>
> wlan0
> ifconfig: SIOCSIFMEDIA (media): Device not configured
>
> But suddenly the wlan0 device is there.
>
> Can anybody fill me in?
>
> --
> Christoph
>
>
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"
>


-- 
Paul B Mahol



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?3a142e751001150817x7b4da53fs16cebd2e097890b4>