Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 12 Jul 2007 11:02:07 +0800
From:      "Daniel Marsh" <jahilliya@gmail.com>
To:        pj <af.gourmet@videotron.ca>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: without SSL
Message-ID:  <ba5e78ea0707112002n68c3680dkc6a57710938b79a5@mail.gmail.com>
In-Reply-To: <46959316.9020402@videotron.ca>
References:  <469511DF.70409@videotron.ca> <D1FF1EB5-6070-4D20-AB8E-1215D091F3AB@mac.com> <46959316.9020402@videotron.ca>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 7/12/07, pj <af.gourmet@videotron.ca> wrote:
>
> Chuck Swiger wrote:
> > On Jul 11, 2007, at 10:22 AM, pj wrote:
> >> I can access apache from my windows machine: "It works"
> >> But I cannot access http://biggie:10000 - message says: try https://...
> >> that does bring up the Webmin page. I know apache listens on port 80,
> >> but why https to get the Webmin page?
> >
> > Umm, so you don't send your Webmin password through the Internet in
> > plain text, rather than via SSL encryption.
> I only use the server locally on my local network so I don't need the SSL.
> >
> > Webmin uses it's own internal webserver, which is unrelated to Apache.
> OK, thanks for that, I didn't know.
> >
> >> I cannot access http or https://biggie:931 (Swat) "Unable to connect"
> >
> > There's no real need to use swat when you've got the ability to edit the
> > samba config directly or via Webmin, but if you really wanted to, you
> > could presumably set it up to run in inetd.conf.  See "man swat".
> Agreed. I don't like to use Webmin except to see if I may have missed
> something. It does not have the correct settings on startup.
> >
> >> Is my configuration wrong for samba? What's with the ssl?
> >
> > You haven't provided any specific information about your Samba config,
> > and most people aren't good at reading minds, so you'll need to either
> > do something like run Samba's "testparms" and/or look over the Samba
> > logfiles....
> I finally found that Samba was looking for a guest account - I had not
> set it up. Now it's working ok.
> >
> >> I tried to reinstall (unsuccessfully -D NOSSL) apache22 without SSL.
> >> How can I disable the SSL I don't need SSL as I am using FBSD6.2 only
> >> on my local network.
> >
> > Unless you've configured an SSL cert, the default ought to be to run
> > Apache without SSL...?
> I have not configured the SSL cert but no matter what I do, apache still
> runs with SSL. According to the manuals, apache is compiled with SSL by
> default for version 2.2.4. I have tried to # the ssl_module in
> httpd.conf with no results at all. That was the first thing I actually
> tried when I saw it was running SSL.
> >
> > ---Chuck
>
Show us your httpd.conf?

It's probably something as simple as uncommenting everything to do with SSL
in httpd.conf, if compiled with SSL, Apache likes to automagically setup a
virtual host using SSL.

There should also be a command line argument to apachectl or httpd that can
be set with apache_flags="--disable-ssl" (or something similar) so the RC
scripts know how to load Apache. Read through
/usr/local/etc/rc.d/apache-script, you'll get some information through that.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?ba5e78ea0707112002n68c3680dkc6a57710938b79a5>