Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 27 Jan 2007 16:24:15 -0800
From:      Oliver Iberien <odilist@sonic.net>
To:        freebsd-questions@freebsd.org
Subject:   Re: how to enable linux flash player in firefox
Message-ID:  <200701271624.16024.odilist@sonic.net>
In-Reply-To: <20070128000606.4D4E116A416@hub.freebsd.org>
References:  <20070128000606.4D4E116A416@hub.freebsd.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Saturday 27 January 2007 16:06, freebsd-questions-request@freebsd.org=20
wrote:
> Subject: Re: how to enable linux flash player in firefox
> To: freebsd-questions@freebsd.org
> Cc: Andreas Davour <ante@update.uu.se>
> Message-ID: <200701280052.26041.tijl@ulyssis.org>
> Content-Type: text/plain; =A0charset=3D"iso-8859-1"
>
> On Saturday 27 January 2007 21:17, Andreas Davour wrote:
> > On Sat, 27 Jan 2007, Tijl Coosemans wrote:
> > > If you want to use flash with native freebsd browsers, you need to use
> > > linuxpluginwrapper (only for FreeBSD 5.x and 6.x). The details are
> > > explained at
> > >
> > > http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/desktop-bro=
ws
> > >ers.html http://freebsd.kde.org/howtos/konqueror-flash.php
> > >
> > > If that doesn't work, please specify which FreeBSD version you're
> > > using and which browser.
> >
> > I followed those instructions and with firefox-2.0.0.1_1,1 it gives this
> > result:
> > /libexec/ld-elf.so.1: /usr/local/lib/pluginwrapper/flash7.so: Undefined
> > symbol "_dlsym"
> >
> > Since I'm now using 6.2-PRERELEASE I guess it could be fixed in the
> > final RELEASE, but it would be nice to know if someone can recognize
> > "_dlsym" and say it is so.
>
> You need to apply the rtld patch mentioned in the first link above.

This is what I used (from an archived posting to this list):

$ cd /usr/src
$ fetch http://people.FreeBSD.org/~nork/rtld_dlsym_hack.diff
$ patch < rtld_dlsym_hack.diff
$ cd libexec/rtld-elf
$ sudo make rtld
$ sudo make install

I also had to make symlinks from libflashplayer.so and flashplayer.xpt to=20
the /npapi and /browser-plugins folders and update /etc/libmap.conf=20
(change "flash6" to "flash7" wherever it appears, basically) to get this to=
=20
work. But it does, in native Firefox, at least. Never seen or heard of it=20
working in Konqueror.

Oliver





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200701271624.16024.odilist>