Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 05 Jul 2007 08:57:55 -0400
From:      Lowell Gilbert <freebsd-questions-local@be-well.ilk.org>
To:        "Dinesh Pandian" <dineshpandian@gmail.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: fetch hangs during Make, portupgrade -a, or portmanager -u..
Message-ID:  <44fy433t4c.fsf@be-well.ilk.org>
In-Reply-To: <3ea3ac8f0707041134o462a9e03od7223643d373ca49@mail.gmail.com> (Dinesh Pandian's message of "Thu\, 5 Jul 2007 02\:34\:16 +0800")
References:  <3ea3ac8f0707041134o462a9e03od7223643d373ca49@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
"Dinesh Pandian" <dineshpandian@gmail.com> writes:

> Please help me out with a really annoying little problem that bugs me
> everytime I try to install applications from ports.
>
> When I try to run portupgrade -a  or  portmanager -u,
> when Make fetches the files from the servers, fetch
> normally hangs randomly sometime through the downloading
> of the distfile. The only solution I've thought about is aborting
> the upgrade procedure and issuing the same command again,
> hoping that fetch resumes where it left off.
>
> In bigger files, > 5MB, I'd have to repeat this process several
> times to download a single distfile.
>
> I've tried setting the FTP_PASSIVE_MODE env ON and OFF
> to no avail.
>
> I can't seem to find a problem with the internet connection
> as httpd and ftpd works perfectly fine!

Is there a firewall in the way?  NAT?

Have you tried using fetch(1) from the command line, with increased
verbosity level?



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?44fy433t4c.fsf>