Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 15 Mar 2016 07:05:13 -0400
From:      Carmel <carmel_ny@outlook.com>
To:        freebsd-questions@freebsd.org
Subject:   Re: Getting wireless network up and running
Message-ID:  <BLU436-SMTP177232924BD6F54F9054D1E80890@phx.gbl>
In-Reply-To: <CAOc73CCDhGqu7vLKJ7kO8rnvPMtzH+U=tMa3x--nEVqUc4ZUNg@mail.gmail.com>
References:  <BLU436-SMTP73D3E85202EF34C6B8BBFD80880@phx.gbl> <CAOc73CCDhGqu7vLKJ7kO8rnvPMtzH+U=tMa3x--nEVqUc4ZUNg@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Mon, 14 Mar 2016 23:50:33 +0100, Ben Woods stated:

> On 14 March 2016 at 20:17, Carmel <carmel_ny@outlook.com> wrote:
> 
> > I cannot seem to get my wireless network up and running.
> >
> > /boot/loader.conf
> > if_bwn_load="YES"  # Broadcom BCM43xx IEEE 802.11 wireless NICs
> >
> > /etc/rc.conf
> > ## Wireless
> > wlans_bwn="wlan0"
> > ifconfig_wlan0="WPA SYNCDHCP"
> >
> > /etc/wpa_supplicant.conf
> > network={
> >         ssid="Wireless-2g"
> >         psk="Secret"
> >         key_mgmt=WPA-PSK
> > }
> >
> > I have run "service netif restart", but the network never comes up.
> > I tried rebooting, but still nothing.
> >
> > If I append a "0" to bwn; ie, wlans_bwn0="wlan0", I get this output:
> >
> > dhclient[1485]: short write: wanted 20 go 0 bytes
> > dhclient[1485]: exiting
> >
> > The system is then frozen solid, so I am forced to reboot into
> > single user mode and remove the entry in "rc.conf".
> >
> > Can anyone tell me what the problem is?
> >
> > Thanks!
> >
> > --
> > Carmel  
> 
> 
> Hi Carmel,
> 
> To help us determine which model of WiFi card you have, can you please
> reply to the list with the output of "pciconf -lv".
> 
> By the way, your rc.conf line should be:
> wlans_bwn0="wlan0"
> 
> Refer to the FreeBSD handbook for more details:
> https://www.freebsd.org/doc/handbook/network-wireless.html
> 
> Refer to the bwn(4) man page for details about the bwn drive and which
> models it supports:
> https://www.freebsd.org/cgi/man.cgi?bwn

I think that this is what you want:

siba_bwn0@pci0:2:1:0:   class=0x028000 card=0x100f1043 chip=0x431814e4 rev=0x02 hdr=0x00
    vendor     = 'Broadcom Corporation'
    device     = 'BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller'
    class      = network

-- 
Carmel



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?BLU436-SMTP177232924BD6F54F9054D1E80890>