Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 4 Feb 2013 20:20:01 GMT
From:      Romain =?iso-8859-1?Q?Tarti=E8re?= <romain@blogreen.org>
To:        mono@FreeBSD.org
Subject:   Re: ports/175518: lang/mono is not configured correctly when building
Message-ID:  <201302042020.r14KK1l2035981@freefall.freebsd.org>

Next in thread | Raw E-Mail | Index | Archive | Help
The following reply was made to PR ports/175518; it has been noted by GNATS.

From: Romain =?iso-8859-1?Q?Tarti=E8re?= <romain@blogreen.org>
To: bug-followup@FreeBSD.org, jack.pappas@tidepowerd.com
Cc:  
Subject: Re: ports/175518: lang/mono is not configured correctly when building
Date: Mon, 4 Feb 2013 21:17:43 +0100

 --neYutvxvOLaeuPCA
 Content-Type: multipart/mixed; boundary="x+6KMIRAuhnl3hBn"
 Content-Disposition: inline
 
 
 --x+6KMIRAuhnl3hBn
 Content-Type: text/plain; charset=iso-8859-1
 Content-Disposition: inline
 Content-Transfer-Encoding: quoted-printable
 
 Hello
 
 I could build lang/mono with just patching the configure script
 (attached) and `mono --gc=3Dsgen` seems ok.
 
 However, you say that mono is not configured correctly without running
 autogen.sh.  Can you please provide more details about what is different
 if you run it and if you directly use configure (assuming both are
 patched to remove 'with_tls=3Dpthread') ?  Or maybe you just wanted to
 avoid to patch this generated 'configure' file ?
 
 We do this because we try to avoit to bring-in all autotools
 dependencies (the port would require adding these extra dependencies to
 the Makefile using:
 
 USE_AUTOTOOLS=3D	libtool:env automake:env autoconf:env aclocal:env
 
 ).
 
 --=20
 Romain Tarti=E8re <romain@blogreen.org>        http://romain.blogreen.org/
 pgp: 8234 9A78 E7C0 B807 0B59  80FF BA4D 1D95 5112 336F (ID: 0x5112336F)
 (plain text =3Dnon-HTML=3D PGP/GPG encrypted/signed e-mail much appreciated)
 
 --x+6KMIRAuhnl3hBn
 Content-Type: text/plain; charset=us-ascii
 Content-Disposition: attachment; filename=patch-configure
 
 
 $FreeBSD$
 
 --- configure.orig
 +++ configure
 @@ -3995,10 +3995,6 @@
  		libgc_threads=pthreads
  		# This doesn't seem to work as of 7.0 on amd64
  		with_sigaltstack=no
 -# TLS is only partially implemented on -CURRENT (compiler support
 -# but NOT library support)
 -#
 -		with_tls=pthread
  		use_sigposix=yes
  		;;
  	*-*-*openbsd*)
 
 --x+6KMIRAuhnl3hBn--
 
 --neYutvxvOLaeuPCA
 Content-Type: application/pgp-signature
 
 -----BEGIN PGP SIGNATURE-----
 Version: GnuPG v2.0.19 (FreeBSD)
 
 iQGcBAEBAgAGBQJREBdnAAoJELpNHZVREjNvxIsMAJCFepid0dqCaZ3HswrRQjFN
 Lzu/Sy2o/xKscV1VfxZBupU+m4HpNsOFYf4EGPM38SrwIRC7P7ID5IJZdxRBbXNq
 6m4iB9B+LP3+Ux5DnZ+SMn3D2c7ka5D+6rnwMKHWuq/R9sThxjVmH09g7TEz3n3s
 z3Z7uK8MgUhoCq41YwbsAk81VsjCZH59xGBFO2HroNDaatzFztIVyXgFYRDp6c7u
 BIzcs9YRKniveZhHkzMyHBcxRxWr2GnhemStPVrE2pGnt+SJXdqrtAa2NZ+EkHXU
 +u/eoLBialZMhHzloVHXFrAUn8bg/1S8idPHgUmo5y70usDXQb7JoQfN2ulk9Pl+
 GiZr1hr1byGcHd5QOB6pAPq4fuxMJ97b3UZveNTBfo5ik2ie3o9xGUXpqem9Brnq
 /zQDU9dOey95WCClPoGKjOJ0Aeccjuz2veQKBg5iRCYPOn2W5oN7JG5vyZOje4hS
 Zj07527HVzX78Zlwk921R9u4ReS4LMJLYLraoWMk5g==
 =+3Ru
 -----END PGP SIGNATURE-----
 
 --neYutvxvOLaeuPCA--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?201302042020.r14KK1l2035981>