Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 18 Jan 2010 02:44:59 +0800
From:      hack988 hack988 <hack988@dev.htwap.com>
To:        Vasily Pupkin <poopkeen@mail.ru>
Cc:        lists@lizardhill.com, php-general@lists.php.net, freebsd-questions@freebsd.org
Subject:   Re: [PHP] RE: Clean PHP 5.2.12 Build Core Dumping / Can't Build Port - FreeBSD 6.1
Message-ID:  <4d03254c1001171044n11c046b8y4eb705470a8c5ac2@mail.gmail.com>
In-Reply-To: <E1NW6fM-00033S-00.poopkeen-mail-ru@f299.mail.ru>
References:  <E1NW6fM-00033S-00.poopkeen-mail-ru@f299.mail.ru>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
I think Vasily Pupkin is right.
http://www.freebsd.org/cgi/cvsweb.cgi/ports/Mk/bsd.port.mk.diff?r1=3D1.630;=
r2=3D1.631;f=3Dh
Found {portsdir}/Mk/bsd.port.mk and make sure the version is higher
than 1.631(2009/12/18)
In another side,your are use "*default tag=3D." in your supfile or /etc/mak=
e.conf?

http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/cvsup.html
mybe you need to use "*default tag=3DRELEASE_6_1_0"

http://www.freebsd.org/cgi/cvsweb.cgi/ports/lang/php5/?only_with_tag=3DRELE=
ASE_6_1_0
php5.x for freebsd 6.1

2010/1/16 Vasily Pupkin <poopkeen@mail.ru>:
> add X11BASE=3D${LOCALBASE} as it is shown below:
>
> #echo "X11BASE=3D${LOCALBASE}" >> /etc/make.conf
>
> The problem is in recent changeset for ports/Mk/bsd.port.mk:
> (http://www.freebsd.org/cgi/cvsweb.cgi/ports/Mk/bsd.port.mk.diff?r1=3D1.6=
30;r2=3D1.631;f=3Dh)
>
> ..if ${X11BASE} !=3D ${LOCALBASE}
> ..BEGIN:
> @${ECHO_MSG} "X11BASE is now deprecated. Unset X11BASE in make.conf and t=
ry again."
> @${FALSE}
> ..endif
>
> The guy commited the revision couldn't imagine that there is no X11BASE o=
n system defined at all while LOCALBASE is defined.
> This bug should be fixed soon because a lot of people will stuck with it =
after ports upgrade.
>
>> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
>> I try a 'make all-depend-list'
>> the error shows up
>> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D
>> which error show ?
>
> # make
> X11BASE is now deprecated. =A0Unset X11BASE in make.conf and try again.
> *** Error code 1
>
> Stop.
>
> That's the error... happens every time, no matter what I try to set/unset=
 in
> /etc/make.conf. I looked through the makefiles to see where X11BASE is
> referenced and I can't find any place where it is to just kill it.
>
>> > This is _exactly_ what I did, and as soon as I try a 'make all-
>> depend-list'
>> > the error shows up. I don't even have the X11 system installed (it's
>> a
>> > headless server, with no GUI).
>> >
>> > This is on a CLEAN 6.1 install, without any upgrades/patches, just
>> straight
>> > off the ISO install and after a portsnap install/extract.
>> >
>> > I tried building it _before_ I updated the ports and it would build a
>> 5.1.2
>> > php ok, but I need 5.2.12. Something has changed in the port between
>> 5.1.2
>> > and 5.2.12
>> >
>> >> 1.add
>> >> WITHOUT_X11=3Dyes
>> >> in /etc/make.conf
>> >> 2.remove
>> >> X11BASE=3D""
>> >> from that file and
>> >>
>> >> 4.make all-depend-list
>> >> 5.make clean all depend soft
>> >> 6.make menuconfig set X11 disable
>> >> 7.make &&make install
>> >>
>> >>
>> >> 2010/1/12 Don O'Neil <li...@lizardhill.com>:
>> >> > Ok.. just for grins I installed a new instance of 6.1, NO Patches,
>> >> just
>> >> > straight off the ISO...
>> >> >
>> >> > I loaded the ports that came WITH the distro, and was able to make
>> >> php 5.1.2
>> >> > ok...
>> >> >
>> >> > When I did a portsnap fetch, portsnap extract, then went into the
>> >> > /usr/ports/lang/php5 and just typed make I get the same error...
>> >> >
>> >> > SO as it seems, the port is broken, at least for working with
>> FreeBSD
>> >> 6.1.
>> >> >
>> >> > Can anyone give me some hints on how to build this sucker by hand?
>> >> Seems as
>> >> > though there are a bunch of patches that are referenced in the
>> >> distinfo
>> >> > file.
>> >> >
>> >> > I REALLY need to get this taken care of asap, any help is
>> >> appreciated.
>> >> >
>> >> > Thanks!
>> >> >
>> >> >> > > I tried adding WITHOUT_X11=3Dyes to /etc/make.conf as well as
>> >> >> X11BASE=3D
>> >> >> > and
>> >> >> > > X11BASE=3D"", but I still get the same error.
>> >> >> >
>> >> >> > Remove them. This makes sure they are not defined, not even
>> >> >> > empty (as in "#define BLA -> symbol 'BLA' is defined").
>> >> >> >
>> >> >> > > Where to go from here? Do I have and old version of something
>> >> that
>> >> >> is
>> >> >> > > causing this? I get this error _right away_ before anything
>> is
>> >> even
>> >> >> > built.
>> >> >> >
>> >> >> > It seems to be a check by the Makefile at port's top level.
>> >> >>
>> >> >> Ok... I have no definition for X11BASE anywhere, not in my env,
>> not
>> >> in
>> >> >> my
>> >> >> /etc/make.conf, nowhwere...
>> >> >>
>> >> >> However, it's still complaining about X11BASE being deprecated. I
>> >> tried
>> >> >> just
>> >> >> adding WITHOUT_X11=3Dyes in /etc/make, and without it. I even
>> searched
>> >> >> all the
>> >> >> Makefiles in /usr/ports, and in the /usr/ports/lang/php5 dir to
>> find
>> >> >> any
>> >> >> reference to X11, or X, or X11BASE, but nada... I don't even know
>> >> where
>> >> >> this
>> >> >> error message is being generated from.
>> >> >>
>> >> >> I can't even do a basic make without it immediately spitting out
>> the
>> >> >> error:
>> >> >>
>> >> >> # make
>> >> >> X11BASE is now deprecated. =A0Unset X11BASE in make.conf and try
>> >> again.
>> >> >> *** Error code 1
>> >> >>
>> >> >> Stop.
>
>
> --
> PHP General Mailing List (http://www.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
>
>



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4d03254c1001171044n11c046b8y4eb705470a8c5ac2>