Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 30 Dec 2006 18:29:01 -0500
From:      Bob McIsaac <bobmc@bobmc.net>
To:        FreeBSD-Questions <freebsd-questions@freebsd.org>
Subject:   FreeBSD on Mini-ITX has web page latency
Message-ID:  <4596F63D.3090203@bobmc.net>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi:

Usability studies say that a person won't wait more than 4 seconds for a
web page download.  FreeBSD using Konqueor or Lynx takes more than 10
seconds.  This is puzzling since ftp transfers at 400kbs, pings of
freebsd.org take 80ms, and top shows CPU is 93% idle.

This is for a EPIA-CN130000 mini-itx with .5gb memory.
http://www.via.com.tw/en/products/mainboards/motherboards.jsp?motherboard_id=400

Via says it works with Windows and Linux. It worked well for me using Mepis
Linux.

Note the message log sees a VT6102 LAN but the board has a 6103. Perhaps
that explains the problem. Otherwise, it must be a protocol issue.

Any suggestions would be welcome

regards,
-Bob-


k: FreeBSD 6.1-RELEASE #0: Sun May  7 04:32:43 UTC 2006
k: root@opus.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
k: Timecounter "i8254" frequency 1193182 Hz quality 0
k: CPU: VIA/IDT Unknown (998.51-MHz 686-class CPU)
k: Origin = "CentaurHauls"  Id = 0x6a9  Stepping = 9
k: 
Features=0xa7c9b8ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,SEP,MTRR,PGE,CMOV,PAT,CLFLUSH,ACPI,MMX,FXSR,SSE,SSE2,TM,PBE>
k: Features2=0x181<SSE3,EST,TM2>
k: real memory  = 469696512 (447 MB)
k: avail memory = 450207744 (429 MB)
k: kbd1 at kbdmux0
k: acpi0: <P4M80P AWRDACPI> on motherboard
k: acpi0: Power Button (fixed)
k: Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
k: acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
k: cpu0: <ACPI CPU> on acpi0
k: acpi_perf0: <ACPI CPU Frequency Control> on cpu0
k: acpi_throttle0: <ACPI CPU Throttling> on cpu0
k: acpi_button0: <Power Button> on acpi0
k: acpi_button1: <Sleep Button> on acpi0
k: pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
k: pci_link2: BIOS IRQ 5 for 0.16.INTC is invalid
k: pci_link2: BIOS IRQ 5 for 0.17.INTC is invalid
k: pci0: <ACPI PCI bus> on pcib0
k: pcib1: <PCI-PCI bridge> at device 1.0 on pci0
k: pci1: <PCI bus> on pcib1
k: pci1: <display, VGA> at device 0.0 (no driver attached)
k: atapci0: <VIA 6420 SATA150 controller> port 
0xfc00-0xfc07,0xf800-0xf803,0xf400-0xf407,0xf000-0xf003,0xec00-0xec0f,0xe800-0xe8ff 
irq 11 at device 15.0 on pci0
k: ata2: <ATA channel 0> on atapci0
k: ata3: <ATA channel 1> on atapci0
k: atapci1: <VIA 8237 UDMA133 controller> port 
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xe400-0xe40f at device 15.1 on pci0
k: ata0: <ATA channel 0> on atapci1
k: ata1: <ATA channel 1> on atapci1
k: uhci0: <VIA 83C572 USB controller> port 0xe000-0xe01f irq 10 at 
device 16.0 on pci0
k: uhci0: [GIANT-LOCKED]
k: usb0: <VIA 83C572 USB controller> on uhci0
k: usb0: USB revision 1.0
k: uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
k: uhub0: 2 ports with 2 removable, self powered
k: uhci1: <VIA 83C572 USB controller> port 0xdc00-0xdc1f irq 10 at 
device 16.1 on pci0
k: uhci1: [GIANT-LOCKED]
k: usb1: <VIA 83C572 USB controller> on uhci1
k: usb1: USB revision 1.0
k: uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
k: uhub1: 2 ports with 2 removable, self powered
k: uhci2: <VIA 83C572 USB controller> port 0xd800-0xd81f irq 11 at 
device 16.2 on pci0
k: uhci2: [GIANT-LOCKED]
k: usb2: <VIA 83C572 USB controller> on uhci2
k: usb2: USB revision 1.0
k: uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
k: uhub2: 2 ports with 2 removable, self powered
k: uhci3: <VIA 83C572 USB controller> port 0xd400-0xd41f irq 11 at 
device 16.3 on pci0
k: uhci3: [GIANT-LOCKED]
k: usb3: <VIA 83C572 USB controller> on uhci3
k: usb3: USB revision 1.0
k: uhub3: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
k: uhub3: 2 ports with 2 removable, self powered
k: ehci0: <VIA VT6202 USB 2.0 controller> mem 0xfdfff000-0xfdfff0ff irq 
9 at device 16.4 on pci0
k: ehci0: [GIANT-LOCKED]
k: usb4: EHCI version 1.0
k: usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
k: usb4: <VIA VT6202 USB 2.0 controller> on ehci0
k: usb4: USB revision 2.0
k: uhub4: VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
k: uhub4: 8 ports with 8 removable, self powered
k: isab0: <PCI-ISA bridge> at device 17.0 on pci0
k: isa0: <ISA bus> on isab0
k: pcm0: <VIA VT8237> port 0xd000-0xd0ff irq 9 at device 17.5 on pci0
k: pcm0: <Unknown AC97 Codec (id = 0x56494182)>
k: pcm0: <VIA DXS Enabled: DXS 4 / SGD 1 / REC 1>
k: vr0: <VIA VT6102 Rhine II 10/100BaseTX> port 0xc800-0xc8ff mem 
0xfdffe000-0xfdffe0ff irq 10 at device 18.0 on pci0
k: miibus0: <MII bus> on vr0
k: ukphy0: <Generic IEEE 802.3u media interface> on miibus0
k: ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
k: vr0: Ethernet address: 00:40:63:e6:41:ba
k: sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 
on acpi0
k: sio0: type 16550A
k: ppc0: <Standard parallel printer port> port 0x378-0x37f irq 7 on acpi0
k: ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
k: ppbus0: <Parallel port bus> on ppc0
k: plip0: <PLIP network interface> on ppbus0
k: lpt0: <Printer> on ppbus0
k: lpt0: Interrupt-driven port
k: ppi0: <Parallel I/O> on ppbus0
k: atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
k: atkbd0: <AT Keyboard> irq 1 on atkbdc0
k: kbd0 at atkbd0
k: atkbd0: [GIANT-LOCKED]
k: psm0: <PS/2 Mouse> irq 12 on atkbdc0
k: psm0: [GIANT-LOCKED]
k: psm0: model IntelliMouse Explorer, device ID 4
k: pmtimer0 on isa0
k: sc0: <System console> at flags 0x100 on isa0
k: sc0: VGA <16 virtual consoles, flags=0x300>
k: sio1: configured irq 3 not in bitmap of probed irqs 0
k: sio1: port may not be enabled
k: vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
k: Timecounter "TSC" frequency 998508102 Hz quality 800
k: Timecounters tick every 1.000 msec
k: ad0: 19541MB <Maxtor 32049H2 YAC614Y0> at ata0-master UDMA100
k: acd0: DVDR <HL-DT-ST DVDRAM GSA-H10N/JL10> at ata1-slave UDMA33
k: Trying to mount root from ufs:/dev/ad0s1a





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4596F63D.3090203>