Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 5 Jul 2007 09:19:00 -0700
From:      "Ted Mittelstaedt" <tedm@toybox.placo.com>
To:        "Chad Perrin" <perrin@apotheon.com>, "FreeBSD Questions" <freebsd-questions@freebsd.org>
Subject:   RE: The worst error message in history belongs to... BIND9!
Message-ID:  <BMEDLGAENEKCJFGODFOCAEDJCAAA.tedm@toybox.placo.com>
In-Reply-To: <20070705073857.GD46581@demeter.hydra>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help


> -----Original Message-----
> From: owner-freebsd-questions@freebsd.org
> [mailto:owner-freebsd-questions@freebsd.org]On Behalf Of Chad Perrin
> Sent: Thursday, July 05, 2007 12:39 AM
> To: FreeBSD Questions
> Subject: Re: The worst error message in history belongs to... BIND9!
> 
> 
> On Wed, Jul 04, 2007 at 08:14:44PM -0700, Garrett Cooper wrote:
> > perryh@pluto.rain.com wrote:
> > >>Except that bash requires all the icky GNU utilities to build so you
> > >>have to GNUify your system.
> > >
> > >And perl doesn't?  It was GPL last I knew.
> > 
> > The entirety of Perl falls under the GPL and Artistic license at this 
> > time. Read the perl-porters archives for more debate on Perl licensing.
> 
> More to the point, Perl is dual-licensed -- redistributable under the
> terms of either the GPL or the Artistic License, at your discretion.

Not correct.  The Artistic license is less restrictive than the GPL so
GPL advocates can take a Perl install and call it GPLd perl - but the
Perl FAQ makes it very clear the intent of the Perl maintainers is not
to use GPL.  As they said, "there is no GNU Perl"

I challenge you to point to one, single Perl scrap of code, that is ONLY
gpled.

As far as I know, anyone submitting patches or modifications to the
Perl maintainers has been required to license their patches under Artistic
for them to be included.

Of course, if people put Perl extensions under GPL the Perl maintainers
cannot help that.  I do not think, however, that any extensions that
are included with the default install are GPL-only.

Ted



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?BMEDLGAENEKCJFGODFOCAEDJCAAA.tedm>