Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 30 Aug 2004 19:16:37 +0200
From:      "Daniel Eriksson" <daniel_k_eriksson@telia.com>
To:        =?iso-8859-1?Q?'S=F8ren_Schmidt'?= <sos@DeepCore.dk>
Cc:        'Pawel Jakub Dawidek' <pjd@freebsd.org>
Subject:   RE: ataraid + geom_stripe problems
Message-ID:  <!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAA/Af1UzkUy0+0atRIKCqjTwEAAAAA@telia.com>
In-Reply-To: <41334E6D.4030601@DeepCore.dk>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
S=F8ren Schmidt wrote:

> Hmm, looks like you re triggering the throtteling code, that=20
> will lead  to catastophic failure as it tosses out interrupts
> causing this:

Yes, that is very likely to be the source of my problems. However, the =
root
cause is still not clear to me. Why would I get an interrupt storm when
geom_stripe tastes the discs when everything else works like a charm?

I have hw.intr_storm_threshold=3D5000 set in /boot/loader.conf so the =
storm is
probably pretty "big". I added that setting back in June when, after
installing a second RocketRAID 454 card, I started getting interrupt =
storms
at boot during device probing. It didn't really help, but ACPI changes =
at
the beginning of August seems to finally have removed those problems.

> Anyhow you would want up to date -current ATA sources as quite a few=20
> problems has been solved..

Hmm, anything in the last 4 days that could affect this (kernel/userland =
was
from 4 days ago)? I don't recall seeing any commits that would be =
relevant.

/Daniel Eriksson




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAA/Af1UzkUy0+0atRIKCqjTwEAAAAA>