Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 5 Jan 2018 02:43:22 +0800
From:      blubee blubeeme <gurenchan@gmail.com>
To:        Per Gunnarsson <p.gunnarsson@yahoo.com>
Cc:        FreeBSD <freebsd-questions@freebsd.org>
Subject:   Re: Static noise with microphone
Message-ID:  <CALM2mEmersOk3t1y2S+ac=nJPHAFihvMBjj7QWCP4D_=4SrVhA@mail.gmail.com>
In-Reply-To: <c2888d59-e1f2-9e07-8a1f-16b0013d1c5b@yahoo.com>
References:  <c2888d59-e1f2-9e07-8a1f-16b0013d1c5b@yahoo.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, Jan 5, 2018 at 2:35 AM, Per Gunnarsson via freebsd-questions <
freebsd-questions@freebsd.org> wrote:

> Hello!
>
> I have attached a microphone (a Mico from Trust) to the mic in on my
> computer, and it produces some static noise. It's not connected to the USB
> port.
>
> Is this just hardware related or is there anything I can change in the
> software to get rid of it?
>
> You can hear the noise here:
>
> http://mustafejen.se:8000/stream.ogg
>
> I found this in my dmesg:
>
> hdac0: <NVIDIA (0x0e0f) HDA Controller> mem 0xfe080000-0xfe083fff at
> device 0.1 on pci3
> hdac1: <AMD (0x157a) HDA Controller> mem 0xfe500000-0xfe503fff at device
> 9.2 on pci0
> hdacc0: <NVIDIA (0x0051) HDA CODEC> at cad 0 on hdac0
> hdaa0: <NVIDIA (0x0051) Audio Function Group> at nid 1 on hdacc0
> pcm0: <NVIDIA (0x0051) (HDMI/DP 8ch)> at nid 5 on hdaa0
> hdacc1: <Realtek ALC662 HDA CODEC> at cad 0 on hdac1
> hdaa1: <Realtek ALC662 Audio Function Group> at nid 1 on hdacc1
> pcm1: <Realtek ALC662 (Analog 2.0+HP/2.0)> at nid 20,27 and 24,26 on hdaa1
> pcm2: <Realtek ALC662 (Analog)> at nid 21 and 25 on hdaa1
>
> [per@konjak ~]$ mixer
> Mixer vol      is currently set to  85:85
> Mixer pcm      is currently set to 100:100
> Mixer speaker  is currently set to  74:74
> Mixer line     is currently set to   1:1
> Mixer mic      is currently set to  90:90
> Mixer mix      is currently set to  74:74
> Mixer rec      is currently set to  85:85
> Mixer igain    is currently set to 100:100
> Mixer ogain    is currently set to 100:100
> Recording source: mic
>
> Regards,
>
> Per Gunnarsson
>
>
>
>
>
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-
> unsubscribe@freebsd.org"
>
> This could be any number of issues.

1) How's the ambient noise in your recording environment?
2) Could be electronic noise from computer components [Is it a laptop or
desktop]
3) The mic could have a very low noise floor, are u doing any filtering?
4) Have you tried any other mic to see if it's the same?

another thing, looking at your hdaa settings did you configure ur pin into
associations and groups?
That pinout looks a bit random.

Check [man snd_hda]



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CALM2mEmersOk3t1y2S+ac=nJPHAFihvMBjj7QWCP4D_=4SrVhA>