Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 19 Jun 2020 10:48:34 -0400
From:      Jerry <jerry@seibercom.net>
To:        freebsd-questions@freebsd.org
Subject:   Re: Update 11.3 > 11.4
Message-ID:  <20200619104834.59a1b113@scorpio.seibercom.net>
In-Reply-To: <CAGBxaX=+_vwivMALz7Rp14NnM7cAkdtdSOYQhqTP3MOAaW+awA@mail.gmail.com>
References:  <20200617134146.00004ce8@seibercom.net> <CAGBxaXmN0wAhZq36H7y7H8f2qnCrjFyos9vPf_em47KCL2TvLA@mail.gmail.com> <20200617165853.000070ca@seibercom.net> <CAGBxaXn-WzZ_J8Ec=FaetqF-p4=dZtWU=b1rgipvs8MD0wsEjA@mail.gmail.com> <20200617195705.000069f0@seibercom.net> <CAGBxaXkvj6aMQeQ2mScsB6VsGye-Y+Z7WDp=q48uS6uCZ2vrVg@mail.gmail.com> <20200618071456.00004fdd@seibercom.net> <20200618134732.48b4c316.freebsd@edvax.de> <20200618083645.00001afc@seibercom.net> <CAGBxaX=nNL8VuM6bsdHjoVWxYZKF5hE3NDjrCUjdAT=y2kj5LA@mail.gmail.com> <941386f3-ce71-6cf6-005c-ab9c159ce998@heuristicsystems.com.au> <20200618184438.00003f41@seibercom.net> <CAGBxaXmSvj7gb_-s1nbCtWhAwFC49dSTG01v=jy9Whv3_WEXGw@mail.gmail.com> <20200619072002.4179e527@scorpio.seibercom.net> <CAGBxaX=+_vwivMALz7Rp14NnM7cAkdtdSOYQhqTP3MOAaW+awA@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
--Sig_/gmw/lD1UC5zJY40qfSMtxlJ
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: quoted-printable

On Fri, 19 Jun 2020 09:42:55 -0400, Aryeh Friedman stated:
>On Fri, Jun 19, 2020 at 7:20 AM Jerry <jerry@seibercom.net> wrote:
>
>> On Thu, 18 Jun 2020 18:55:24 -0400, Aryeh Friedman stated: =20
>> >On Thu, Jun 18, 2020 at 6:45 PM Jerry <jerry@seibercom.net> wrote:
>> > =20
>> >> On Fri, 19 Jun 2020 08:19:12 +1000, Dewayne Geraghty commented: =20
>> >> >Jerry,
>> >> >
>> >> >Aryeh's suggestion of determining the cause of the problem would
>> >> >be beneficial as the PR
>> >> >https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=3D237666
>> >> >appears to be caught in a non-reproducability trap. Eg "I have
>> >> >an X on version Y and no bug" will not allay anyone's concerns.
>> >> >
>> >> >Also reply 103 asserts that this problem doesn't exist on 11 (ie
>> >> >prior to 11.4). Perhaps pulling the iso's for 11.4 and using on a
>> >> >machine that reproduces the bug with 12.1 might be a more
>> >> >efficient path? =20
>> >>
>> >> It doesn't exist on 11.x at ll. If you read through the comments,
>> >> etcetera, it was mentioned that it is most likely a regression
>> >> problem. Regression bugs have a nasty habit of spreading.
>> >> =20
>> >
>> >Especially if people refuse to actual test it to see if it is a bug
>> >or not on their system.  Since it is not on mine my test is
>> >meaningless but your might not be and might help debug it so if you
>> >care about helping the community like you do you should try it and
>> >make a complete bug report as possible.   But as I said it happens
>> >in enough odd different places that it is 90% likely user error not
>> >an actual bug and you just falling for FUD if you are not willing
>> >to help figure it out. =20
>>
>> I can confirm that the bug exists on at least a Dell XPS 8930 with 32
>> GB RAM and Intel i3 Processor. The machine was purchased as a low-end
>> replacement for a PC that was dying. Its sole purpose was to run a
>> lightly used web-server and mail-server.
>> =20
>
>If you call that low end then I hate to see what you call high end.
>To most people low end means walking into the store and pointing to the
>nearest machine in the $300-$500 range and saying "give me that one" .
>None of those machines would have anywhere near those specs.  Note a
>perfectly serviceable web/mail server can do in 4 to 8 GB for example.
>
>
>> I can confirm that it works with every version of 11.x and no
>> versions of 12.x. I have never tested it on 10.x or 13.x however.
>> =20
>
>If you never tried 13.X (aka -current) then you have no way to know if
>it is fixed or not (for all you know the problem could have been MFC'ed
>already).

A) I am not using 13.x or 5.x or any other X.x. I am using 11.4 which
works and no version of 12.x does. I am dealing with facts, not
speculations.

>> I have went to the lengths of using the manufacturers disk to erase
>> and format the HD and resetting the BIOS to defaults. I never messed
>> with the defaults anyway.
>> =20
>
>Some features of FreeBSD require you to mess with the defaults like if
>you want to do VM's you need to often turn on virtualization which is
>usually off by default.   So saying you never mess with defaults just
>reconfirms that you are unwilling to try every possible source user
>error before saying it is the OS's fault.  (See below for other cases
>of you doing the same thing)

If I was running a VM, that would be a different scenerio.

>> The error starts as soon as the CD attempts to boot-up FreeBSD 12.x.
>> Assuming, incorrectly, that the disk was bad I did a fresh download
>> and burned a new CD. The sane problem existed.
>> =20
>
>Are you sure the CD reader can handle the size of the 12.X CD and are
>you sure your burn software can do the same?  This is not a pointless
>question since there are documented issues with the size of the CD
>image vs. the capabilities of some hardware and/or FreeBSD (
>https://docs.freebsd.org/cgi/getmsg.cgi?fetch=3D162309+0+current/freebsd-q=
uestions
>)

I am well aware of thst thread. And no, the problem only exists on that
machine. I did try the disk on the machine I replaced and guess what
... it worked fine. Your hypothesis is rubbish.

>Did you try a different install medium like a USB memory stick or DVD
>(vs. CD)?

Actually, yes I did. I used a DVD on my last attempt last month to
install 12.1

>Did you try to boot the CD image on a different machine to see if
>somehow your downloads were corrupt?

Already answered above.

>This is not a user error. More than one person on more than one
>> platform is experiencing this bug. I contacted Dell technical
>> support. They confirmed that the bug exists, there is even a
>> reference to it on their community bulletin board. They went on to
>> say that their product was tested against Windows 10 and
>> passed,(obviously) and against Linux and worked as intended. They
>> stated that they DO NOT test against or guarantee their products
>> will work with FreeBSD. They were also aware that a bug report had
>> been filed against it in the FreeBSD Bugzilla. I really wish I had
>> been made aware of it too. I made the suggestion that they list OSs
>> that their equipment will not work with. They nicely stated that an
>> operation of that extent would be beyond the scope of their
>> technical department since their are potentially hundreds of
>> thousands of individual configurations. I suggested that they test
>> against a base OS installation, but they declined saying they do not
>> test against FreeBSD. They would welcome me doing it though. Since
>> they declined to supply me with their equipment free of charge to
>> undertake this endeavor, I declined.
>>
>> The saying, "If you are not part of the solution, you are part of the
>> problem", is certainly apropos to you in this incident.
>> =20
>
>FreeBSD is a "some assembly" required OS and you are refusing to even
>try the assembly because of either not understanding the directions or
>not being willing to actually test a part to see if it is defective
>instead of just calling it defective and returning the whole piece of
>furniture (or whatever you attempting to assemble).   At best not
>doing this should disqualify you from complaining about the issue
>since you have no direct proof it is not user error.  At worst it is
>being a spoiled rich kid (FreeBSD was not designed for you, it was
>designed for people who are willing to experiment with different
>things before assuming it is not a user error).   The "rest of us"
>would not have the option  of just returning the machine (due it being
>built out of spare parts and/or otherwise recycled/built in such a way
>that it was effectively bought "as is").   This means we have learned
>to tinker with what might look like a defective part and first but
>instead is just something we didn't understand the instruction on to
>make it work.
>
>Bottom line so even worse than being a part of the problem you are
>becoming the problem.   If you want a good example of how to do stuff
>right instead of being a part of the problem see
>https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=3D247363 (especially
>the last comment)

The only logical conclusion here is that you don't have a clue what you
are talking about. Don't waste my time. It has been confirmed as a bug
by several individuals. The people working on correcting it have
confired it is a bug. The problem is it is an 'edge' case and not easy
to isolate. Why don't you go tell them they they don't know what they
are talking about. Tell anyone you want; just don't waste my time.

--=20
Jerry

--Sig_/gmw/lD1UC5zJY40qfSMtxlJ
Content-Type: application/pgp-signature
Content-Description: OpenPGP digital signature

-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEIQb/tTwl6I1ueEVtOHMGOIfexWQFAl7s0EIACgkQOHMGOIfe
xWTD/gf8DtgwDrn8sti0N9KulIl+NPMxybE1k/GOxJyPdqGmJGaUC/jhbVXtsOFQ
sOJX64hrSCOZPo7zXdlCEAo4qIFrpi9Dh1eUhkxxskKSSR8DQKXozcxnsg5e4CGD
LJhGuQP7tkl8u3zIjXSvkEvCh/DdZmm574E34D6NtxEw1q+YkcDBnwDqLinJL/9h
J9vYAUMVbvKTSixZ3MV5e1Sa9D9uWFXKkUahRXe39y6gdpRbCiGVzUAoZNbUwLst
zeSVSMcNUsQrPdcXwILx8gpK00ao/TT6Rlg/6ABB1S2UmwRI6nMtFv46d4MmxrSc
bfi4+RDdH8cHk20nG2MLcHYxBQe7sw==
=wLOn
-----END PGP SIGNATURE-----

--Sig_/gmw/lD1UC5zJY40qfSMtxlJ--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20200619104834.59a1b113>