Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 29 Sep 2006 15:43:21 -0400
From:      Jason Lixfeld <jason+lists.freebsd-questions@lixfeld.ca>
To:        Kris Kennaway <kris@obsecurity.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: 6.1-RELEASE compiler/preprocessor problem?
Message-ID:  <CA6F9A37-7726-432F-80F8-BB635E38E81F@lixfeld.ca>
In-Reply-To: <20060929192143.GA34402@xor.obsecurity.org>
References:  <B383188E-14D7-4D5D-BB88-543198667BDC@lixfeld.ca> <20060929192143.GA34402@xor.obsecurity.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

On 29-Sep-06, at 3:21 PM, Kris Kennaway wrote:

> On Fri, Sep 29, 2006 at 03:15:50PM -0400, Jason Lixfeld wrote:
>
>> Not claiming to know much about anything, but can't seem to get this
>> to compile.  The only things that stand out are the preprocessor
>> error (which I don't know enough about to even begin to troubleshoot)
>> and the tiffio.h no such file error.  I can vouch for the existence
>> of the tiffio.h in /usr/local/include, but not sure if that's
>> actually where it's trying to find it.
>
> It's not, as the lack of -I/usr/local/include says.  This is supposed
> to be provided by the port Makefile:
>
> CFLAGS+=        -I${LOCALBASE}/include

This is in the makefile.

> so make sure all files in the port are up-to-date and you have made no
> other changes yourself.

No changes.  Just to be sure, I will re-cvsup that port.

> If you still have problems, your first point of call for port problems
> should be the port maintainer, since they're the ones who have
> volunteered to help users with problems about that port.

Good point.  Thank you!

> Kris




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CA6F9A37-7726-432F-80F8-BB635E38E81F>