Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 29 Nov 2017 15:51:35 +0000
From:      bugzilla-noreply@freebsd.org
To:        freebsd-bugs@FreeBSD.org
Subject:   [Bug 223969] EFI boot failure when using UFS disk
Message-ID:  <bug-223969-8-GqvsYSaivh@https.bugs.freebsd.org/bugzilla/>
In-Reply-To: <bug-223969-8@https.bugs.freebsd.org/bugzilla/>
References:  <bug-223969-8@https.bugs.freebsd.org/bugzilla/>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=3D223969

--- Comment #6 from Toomas Soome <tsoome@freebsd.org> ---
Could you test this update:

Index: stand/efi/libefi/efipart.c
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
--- stand/efi/libefi/efipart.c  (revision 326368)
+++ stand/efi/libefi/efipart.c  (working copy)
@@ -257,6 +257,15 @@
                    !blkio->Media->MediaPresent) {
                        return (false);
                }
+
+               /*
+                * iPXE stub Block IO protocol. Test for "iPXE" in MediaID
+                * and BlockSize.
+                */
+               if (blkio->Media->MediaId =3D=3D 0x69505845U &&
+                   blkio->Media->BlockSize =3D=3D 1) {
+                       return (false);
+               }
        }
        return (true);
 }

--=20
You are receiving this mail because:
You are the assignee for the bug.=



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?bug-223969-8-GqvsYSaivh>