Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 11 Sep 2018 14:55:54 +0000
From:      Lorenzo Salvadore <phascolarctos@protonmail.ch>
To:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Re: how to enforce one version of python
Message-ID:  <uf30V3vkIXr3M2ToB3lBYQD_4CPsr3JYOmzlavWHu-uMH54kCvrJqeTdAjPKF1OshRqUOXp8YZfDQ9wd-EeK5-C-OqC1YNdqWrdFuO7vu-s=@protonmail.ch>
In-Reply-To: <kvT5V2PiAa5Gbk5_Lh2ozHwNbEybcaLLWNFgpsFVXI5pGdz06FW4rNgDP93Kd35Irqevh_y1kJ0hFgMj8Id218G6yXQQZBrhmyoNmJRBRoE=@protonmail.ch>
References:  <fcb50bfe-c21f-a3ba-9d9f-2af92c3565d4@zyxst.net> <kvT5V2PiAa5Gbk5_Lh2ozHwNbEybcaLLWNFgpsFVXI5pGdz06FW4rNgDP93Kd35Irqevh_y1kJ0hFgMj8Id218G6yXQQZBrhmyoNmJRBRoE=@protonmail.ch>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
> Hi,
> There are a number of ports that seem to have their own preferential
> flavour of python, and some for example want to install python27 and
> python36 in the same place, and it's a pain when using portupgrade or
> similar tools.
> I have this in my /etc/make.conf:
> DEFAULT_VERSIONS+=3D python=3D2.7
> Is this incorrect? I assume it must be, as for example devel/pylint
> (pylint-py27-1.9.2) wants to upgrade to pylint-py36-2.1.1
> thanks,
>
> J.

I think the correct line would be the following:

FLAVOR?=3D py27

Lorenzo Salvadore.





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?uf30V3vkIXr3M2ToB3lBYQD_4CPsr3JYOmzlavWHu-uMH54kCvrJqeTdAjPKF1OshRqUOXp8YZfDQ9wd-EeK5-C-OqC1YNdqWrdFuO7vu-s=>