Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 19 Jan 2009 11:20:42 +0700 (ICT)
From:      Olivier Nicole <on@cs.ait.ac.th>
To:        jhall@socket.net
Cc:        freebsd-questions@freebsd.org
Subject:   Re: ldapsearch question
Message-ID:  <200901190420.n0J4KgYQ086801@banyan.cs.ait.ac.th>
In-Reply-To: <9DFC15B7-CA66-4717-956D-1A761E8539AD@socket.net> (message from Jay Hall on Sun, 18 Jan 2009 22:04:50 -0600)
References:  <C73DF42B-1235-4671-B9D0-FC112C4D9504@socket.net> <200901190353.n0J3rwFX083175@banyan.cs.ait.ac.th> <9DFC15B7-CA66-4717-956D-1A761E8539AD@socket.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
> I receive the same results using mail=*.  Following is the latest  
> ldapsearch command.
> 
> ldapsearch -D "cn=admin_user,cn=users,dc=xx,dc=com" -x -w "password" - 
> h 10.129.10.42 -p 3268 -b 'dc=abc,dc=com' -s sub '(! 
> (objectclass=computer))' '(mail=*)' dn mail
> 
> Is it possible to search on the attribute, mail, not being present?

Hummm, that may be a feature from Active directory.

When searching in LDAP:

attribue=* means the attribute is present and set

!(attribute=*) means the attribute is not set or the attribute is not
    present (this attribute does not exist for that object, or the
    attribute exist for the object but is not being used)

I am not using active directory but OpenLDAP, so I canno help further.

Bests,

Olivier



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200901190420.n0J4KgYQ086801>