Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 28 Jan 2009 21:44:06 -0500
From:      Robert Noland <rnoland@FreeBSD.org>
To:        Warren Block <wblock@wonkity.com>
Cc:        freebsd-x11@FreeBSD.org
Subject:   Re: Xorg 7.4 breaks mga with G450
Message-ID:  <1233197046.1779.11.camel@wombat.2hip.net>
In-Reply-To: <alpine.BSF.2.00.0901261613410.2383@wonkity.com>
References:  <+$PUWxC8yOfJFwC1@lap.knigma.org> <1232939280.1973.7.camel@wombat.2hip.net> <alpine.BSF.2.00.0901260943380.1030@wonkity.com> <1233002689.88679.24.camel@squirrel.corp.cox.com> <alpine.BSF.2.00.0901261613410.2383@wonkity.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

--=-hdPKkGTI5DSLN1o35XxZ
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

On Mon, 2009-01-26 at 16:23 -0700, Warren Block wrote:
> On Mon, 26 Jan 2009, Robert Noland wrote:
>=20
> > On Mon, 2009-01-26 at 10:04 -0700, Warren Block wrote:
> >> On Sun, 25 Jan 2009, Robert Noland wrote:
> >>
> >>> On Sun, 2009-01-25 at 22:50 +0000, Mark Knight wrote:
> >>>> Hi,
> >>>>
> >>>> I've been using the same PC with a Matrox G450 on AGP with a trusty =
old
> >>>> iiyama CRT monitor (Vision Master pro 410) for years.  System is run=
ning
> >>>> FreeBSD 6.4-RELEASE-p1
> >>>>
> >>>> Having just upgraded to Xorg 7.4 from 7.3 and following the instruct=
ions
> >>>> in UPDATING I cannot get a stable picture.
> >>>>
> >>>> Using my stock xorg.conf (see below), or a brand new config version
> >>>> created by "Xorg -configure" I get an extremely noisy (but stable) i=
mage
> >>>> if I lower resultion from my normal 1280x1024 to 1027x768.  At the
> >>>> standard resolution the monitor is unable to sync.
> >>>>
> >>>>    http://www.knigma.org.uk/scratch/Xorg.0.log
> >>>>    http://www.knigma.org.uk/scratch/xorg.conf
> >>>>
> >>>> I've tried with and without DDC and with and without
> >>>> HorizSync/VertRefresh and with and without SyncOnGreen (my monitor h=
as
> >>>> always product a slightly sharper picture with the latter).
> >>>>
> >>>> Any ideas?
> >>>
> >>> I think your on the right track... It sounds like the mode calculatio=
n
> >>> is off...  I won't have access to mga hardware before next weekend, b=
ut
> >>> even then mine is connected to a panel.
> >>
> >> My G450 does the same (sync problem/noisy picture) on an LCD.
> >> mga-1.4.9 does it too, so I'd suspect a change in xorg-server.
> >
> > I just discovered an issue... Can you forcibly rebuild the 1.4.9 driver
> > against the new server and see if that works?
>=20
> Not being sure what you mean by "forcibly".  I have a copy of mga-1.4.9=20
> and mga-1.9.100 in /usr/ports/x11-drivers in addition to the current mga=20
> (1.9.100).  I've been deinstalling (and cleaning) one before=20
> installing the other.

Ok, can one or both of you guys load up the vesa driver.  Assuming that
that doesn't show the same issue, send me and xorg.log from both vesa
and mga.

robert.

> -Warren Block * Rapid City, South Dakota USA
>=20

--=-hdPKkGTI5DSLN1o35XxZ
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.10 (FreeBSD)

iEYEABECAAYFAkmBF/YACgkQM4TrQ4qfROMPxgCdFn3nQ4u5weNmO98QYbk96Yyf
dKQAnRGauJ6Mb0OoXGXVCOA53uyYA8cT
=3s1o
-----END PGP SIGNATURE-----

--=-hdPKkGTI5DSLN1o35XxZ--




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?1233197046.1779.11.camel>