Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 11 Aug 2004 19:31:51 +0200
From:      "Daniel Eriksson" <daniel_k_eriksson@telia.com>
To:        "'Nate Lawson'" <njl@freebsd.org>, <freebsd-current@freebsd.org>
Subject:   RE: cvs commit: src/sys/dev/acpica acpi_pci_link.c acpi_pcib.c acpi_pcib_acpi.c acpi_pcib_pci.c acpi_pcibvar.h
Message-ID:  <!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAAThZ4MpwZjU+KndAha//XewEAAAAA@telia.com>
In-Reply-To: <200408111452.i7BEqoNN071668@repoman.freebsd.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Nate Lawson wrote:

>   Modified files:
>     sys/dev/acpica       acpi_pci_link.c acpi_pcib.c 
>                          acpi_pcib_acpi.c acpi_pcib_pci.c 
>                          acpi_pcibvar.h 
>   Log:
>   Re-work ACPI PCI IRQ routing (_PRT, link devices).  The old 
> approach was
>   incomplete in that the PRT routing was not aware of link 
> programming.
>   Fix this by doing all routing through the link devices.  

This(?) breaks interrupt routing pretty badly on ASUS A7V600-X (VIA KT-600
chipset).

A kernel/userland from 2004.08.09.13.00.00 works just fine (sorry, no dmesg
available right now), but a kernel/userland from 2004.08.11.15.00.00 breaks
routing of interrupts to (at least) two HighPoint RocketRAID 454 cards.

Below is part of the dmesg from a boot with ACPI on. Does it matter that
"PnP OS installed" is turned off in the BIOS? I will run some more tests
later tonight and report the results here. This is just a FYI that something
might be broken...

/Daniel Eriksson


/boot/kernel/acpi.ko text=0x44df8 data=0x1b84+0xd2c
syms=[0x4+0x6ca0+0x4+0x8d16]
KDB: debugger backends: ddb
KDB: current backend: ddb
Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.2-CURRENT #1: Wed Aug 11 18:29:23 CEST 2004
    daniel@fortify.satra.zapto.org:/usr/obj/usr/src/sys/FORTIFY
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(TM) XP 2500+ (1999.78-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x6a0  Stepping = 0
 
Features=0x383fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,
CMOV,PAT,PSE36,MMX,FXSR,SSE>
  AMD Features=0xc0400000<AMIE,DSP,3DNow!>
real memory  = 1342156800 (1279 MB)
avail memory = 1305075712 (1244 MB)
ACPI APIC Table: <ASUS   A7V600-X>
ioapic0: Changing APIC ID to 2
ioapic0 <Version 0.3> irqs 0-23 on motherboard
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <ASUS A7V600-X> on motherboard
acpi0: [GIANT-LOCKED]
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <32-bit timer at 3.579545MHz> port 0xe408-0xe40b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA 8377 (Apollo KT400/KT400A/KT600) host to PCI bridge> mem
0xf8000000-0xfbffffff at device 0.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
atapci0: <HighPoint HPT374 (channel 0+1) UDMA133 controller> port
0xb400-0xb4ff,0xb800-0xb803,0xd000-0xd007,0xd400-0xd403,0xd800-0xd807 irq 11
at device 10.0 on pci0
ata2: at 0xd800 on atapci0
ata3: at 0xd000 on atapci0
atapci1: <HighPoint HPT374 (channel 2+3) UDMA133 controller> port
0x9800-0x98ff,0xa000-0xa003,0xa400-0xa407,0xa800-0xa803,0xb000-0xb007 irq 11
at device 10.1 on pci0
ata4: at 0xb000 on atapci1
ata5: at 0xa400 on atapci1
ahc0: <Adaptec 29160 Ultra160 SCSI adapter> port 0x9400-0x94ff mem
0xed800000-0xed800fff irq 3 at device 12.0 on pci0
ahc0: [GIANT-LOCKED]
aic7892: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs
atapci2: <HighPoint HPT374 (channel 0+1) UDMA133 controller> port
0x7800-0x78ff,0x8000-0x8003,0x8400-0x8407,0x8800-0x8803,0x9000-0x9007 irq 10
at device 14.0 on pci0
ata6: at 0x9000 on atapci2
ata7: at 0x8400 on atapci2
atapci3: <HighPoint HPT374 (channel 2+3) UDMA133 controller> port
0x6000-0x60ff,0x6400-0x6403,0x6800-0x6807,0x7000-0x7003,0x7400-0x7407 irq 10
at device 14.1 on pci0
ata8: at 0x7400 on atapci3
ata9: at 0x6800 on atapci3
atapci4: <VIA 6420 SATA150 controller> port
0x4000-0x40ff,0x4400-0x440f,0x4800-0x4803,0x5000-0x5007,0x5400-0x5403,0x5800
-0x5807 irq 5 at device 15.0 on pci0
ata10: at 0x5800 on atapci4
ata11: at 0x5000 on atapci4
atapci5: <VIA 8237 UDMA133 controller> port
0x3800-0x380f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 irq 14 at device 15.1 on
pci0
ata0: at 0x1f0 irq 14 on atapci5
ata1: at 0x170 irq 15 on atapci5
uhci0: <VIA 83C572 USB controller> port 0x3400-0x341f irq 7 at device 16.0
on pci0
uhci0: [GIANT-LOCKED]
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0x3000-0x301f irq 7 at device 16.1
on pci0
uhci1: [GIANT-LOCKED]
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <VIA 83C572 USB controller> port 0x2800-0x281f irq 5 at device 16.2
on pci0
uhci2: [GIANT-LOCKED]
usb2: <VIA 83C572 USB controller> on uhci2
usb2: USB revision 1.0
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3: <VIA 83C572 USB controller> port 0x2400-0x241f irq 5 at device 16.3
on pci0
uhci3: [GIANT-LOCKED]
usb3: <VIA 83C572 USB controller> on uhci3
usb3: USB revision 1.0
uhub3: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0: <VIA VT6202 USB 2.0 controller> mem 0xed000000-0xed0000ff irq 9 at
device 16.4 on pci0
ehci0: [GIANT-LOCKED]
ehci_pci_attach: companion usb0
ehci_pci_attach: companion usb1
ehci_pci_attach: companion usb2
ehci_pci_attach: companion usb3
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: <VIA VT6202 USB 2.0 controller> on ehci0
usb4: USB revision 2.0
uhub4: VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
vr0: <VIA VT6102 Rhine II 10/100BaseTX> port 0x2000-0x20ff mem
0xec800000-0xec8000ff irq 7 at device 18.0 on pci0
miibus0: <MII bus> on vr0
rlphy0: <RTL8201L 10/100 media interface> on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
vr0: Ethernet address: 00:0e:a6:1f:29:1e
vr0: [GIANT-LOCKED]
re0: <RealTek 8110S Single-chip Gigabit Ethernet> port 0x1800-0x18ff mem
0xec000000-0xec0000ff irq 12 at device 19.0 on pci0
miibus1: <MII bus> on re0
rgephy0: <RTL8169S/8110S media interface> on miibus1
rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,
1000baseTX-FDX, auto
re0: Ethernet address: 00:50:fc:f8:c6:81
re0: [GIANT-LOCKED]
fdc0: <floppy drive controller> port 0x3f7,0x3f2-0x3f5 irq 6 drq 2 on acpi0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A, console
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
orm0: <ISA Option ROM> at iomem 0xc0000-0xcafff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x100>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1999782373 Hz quality 800
Timecounters tick every 1.000 msec
ipfw2 initialized, divert enabled, rule-based forwarding enabled, default to
accept, logging unlimited
ad0: 114473MB <ST3120022A/3.06> [232581/16/63] at ata0-master UDMA100
ad1: 114473MB <ST3120022A/3.06> [232581/16/63] at ata0-slave UDMA100
ad2: 117800MB <IC35L120AVV207-0/V24OA66A> [239340/16/63] at ata1-master
UDMA100
ad3: 117800MB <IC35L120AVV207-0/V24OA66A> [239340/16/63] at ata1-slave
UDMA100
ata2-slave: FAILURE - ATA_IDENTIFY no interrupt
ata2-slave: FAILURE - ATA_IDENTIFY no interrupt
ata2-master: FAILURE - ATA_IDENTIFY no interrupt
ata2-master: FAILURE - ATA_IDENTIFY no interrupt
ata3-slave: FAILURE - ATA_IDENTIFY no interrupt
ata3-slave: FAILURE - ATA_IDENTIFY no interrupt
ata3-master: FAILURE - ATA_IDENTIFY no interrupt
ata3-master: FAILURE - ATA_IDENTIFY no interrupt
ata4-slave: FAILURE - ATA_IDENTIFY no interrupt
ata4-slave: FAILURE - ATA_IDENTIFY no interrupt
ata4-master: FAILURE - ATA_IDENTIFY no interrupt
[...]




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAAThZ4MpwZjU+KndAha//XewEAAAAA>