Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 28 Apr 2020 19:11:42 -0400
From:      ajtiM <starikarp@dismail.de>
To:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Firefox 76.0,1
Message-ID:  <20200428191142.5cf10bbc@dismail.de>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi!

I do not have installed Python 2.7 but today I want to update Firefox
to version 76.0,1 and it pull me Python 2.7.
I have checkmarks on DBUS, FFMPEG, GCONF, OPTIMAZED_CFLAGS, PROFILE and
SNDIO.
 make
=3D=3D=3D>   firefox-76.0,1 depends on package: nspr>=3D4.25 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: nss>=3D3.51.1 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: icu>=3D64.1,1 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: libevent>=3D2.1.8 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: harfbuzz>=3D2.6.4 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: graphite2>=3D1.3.14 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: png>=3D1.6.35 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: libvpx>=3D1.8.2 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: py37-sqlite3>0 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: v4l_compat>0 - found
=3D=3D=3D>   firefox-76.0,1 depends on executable: autoconf-2.13 - found
=3D=3D=3D>   firefox-76.0,1 depends on executable: nasm - found
=3D=3D=3D>   firefox-76.0,1 depends on executable: yasm - found
=3D=3D=3D>   firefox-76.0,1 depends on executable: zip - found
=3D=3D=3D>   firefox-76.0,1 depends on package: llvm90>0 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: rust-cbindgen>=3D0.13.1 - f=
ound
=3D=3D=3D>   firefox-76.0,1 depends on package: rust>=3D1.41 - found
=3D=3D=3D>   firefox-76.0,1 depends on file: /usr/local/bin/python3.7 - fou=
nd
=3D=3D=3D>   firefox-76.0,1 depends on executable: node - found
=3D=3D=3D>   firefox-76.0,1 depends on file: /usr/local/bin/clang90 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: libnotify>0 - found
=3D=3D=3D>   firefox-76.0,1 depends on file: /usr/local/include/sndio.h -
found =3D=3D=3D>   firefox-76.0,1 depends on executable: gmake - found
=3D=3D=3D>   firefox-76.0,1 depends on package: libiconv>=3D1.14_11 - found
=3D=3D=3D>   firefox-76.0,1 depends on package: pkgconf>=3D1.3.0_1 - found
=3D=3D=3D>   firefox-76.0,1 depends on file: /usr/local/bin/python2.7 - not
found =3D=3D=3D>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.

=3D=3D=3D>  python27-2.7.17_1 has known vulnerabilities:
python27-2.7.17_1 is vulnerable:
Python -- Regular Expression DoS attack against client
CVE: CVE-2020-8492
WWW:
https://vuxml.FreeBSD.org/freebsd/a27b0bb6-84fc-11ea-b5b4-641c67a117d8.html

1 problem(s) in 1 installed package(s) found.
=3D> Please update your ports tree and try again.
=3D> Note: Vulnerable ports are marked as such even if there is no update
available. =3D> If you wish to ignore this vulnerability rebuild with
'make DISABLE_VULNERABILITIES=3Dyes' *** Error code 1

Why I need it Python 2.7, please?

Thank you.

--=20
Ernst Lubitsch=E2=80=99s Ninotchka:=20

=E2=80=9C=E2=80=98Waiter! A cup of coffee without cream, please!=E2=80=99 =
=E2=80=98I=E2=80=99m sorry, sir, we
have no cream, only milk, so can it be a coffee without milk?=E2=80=99=E2=
=80=9D=20



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20200428191142.5cf10bbc>