Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 17 Apr 2018 10:55:53 +0000
From:      Carmel NY <carmel_ny@outlook.com>
To:        FreeBSD <freebsd-questions@freebsd.org>
Subject:   Re: [hasse@bara1.se: dovecot error on boot up] (RePost)
Message-ID:  <BN6PR2001MB1730E02213F3A62FA8143CAD80B70@BN6PR2001MB1730.namprd20.prod.outlook.com>
In-Reply-To: <776ACEE3-986C-411B-A29A-74924A0D1603@cretaforce.gr>
References:  <20180415085734.GA2060@ymer.bara1.se> <776ACEE3-986C-411B-A29A-74924A0D1603@cretaforce.gr>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Mon, 16 Apr 2018 02:44:45 +0300, Christos Chatzaras stated:

>> Hello
>> After latest update/upgrade I get this for me strange error on the
>> boot up screen :
>>=20
>> dovecot error:t_readlink(var/run/dovecot//dovecot.conf) failed: readlink=
()
>> failed: No such file or directory Then : Starting dovecot
>>  =20
>
>What was the previous version of dovecot and what the new version?
>
>I use dovecot-2.3.1 and there is a new version in ports tree 2.3.1_1 which=
 I
>haven't upgrade yet.
>
>Do you see this error only on your screen or it shows it in logs too? I wa=
nt
>to try to reproduce this error and need to know if I need KVM connected to
>the server.
>
>/var/run/dovecot/dovecot.conf is a link to /usr/local/etc/dovecot/dovecot.=
conf
>
>Do you have chroot for dovecot? Maybe /var/run/dovecot is not mounted yet
>when dovecot starts and this is the reason for this message.

It only appears upon boot up; not if it is subsequently stopped and restart=
ed.
There is no mention of the error in the dovecot logs.

I am running the latest version of dovecot and it is not chrooted.

--=20
Carmel



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?BN6PR2001MB1730E02213F3A62FA8143CAD80B70>