Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 21 Dec 2002 03:25:16 +0100
From:      Jens Rehsack <rehsack@liwing.de>
To:        Muhannad Asfour <muhannad07@cogeco.ca>
Cc:        current@freebsd.org
Subject:   Re: mod_php4 4.2.3 under 5.0-CURRENT
Message-ID:  <3E03D10C.6030608@liwing.de>
References:  <000001c2a88e$15fc3db0$6401a8c0@winxp>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Muhannad Asfour wrote:
> Hi, I was searching on groups.google.com recently to try to find out how 
> to get mod_php4 compiled under 5.0-CURRENT, and I found your message and 
> thought you might be of some assistance.  I recently built a new server 
> and wanted to run 5.0-CURRENT on it.  I installed 5.0, cvsupped sources, 
> rebuilt world, updated all of the ports.  Everything works great, except 
> the mod_php4 won?t build (Yes, I e-mailed the port maintainer, no reply 
> yet) :( .  I was wondering if you got it to build?  Here is my error if 
> you might be able to help me:
> 
>  
> 
> ===>  Building for mod_php4-4.2.3
> 
> Making all in Zend
> 
> /bin/sh ../libtool --silent --mode=compile cc -DHAVE_CONFIG_H -I. -I. 
> -I../main   -DMOD_SSL=208112 -DMOD_PERL -DUSE_PERL_SSI 
> -DAPPLLIB_EXP="/usr/local/lib/perl5/5.6.1/BSDPAN" -DEAPI 
> -DAPPLLIB_EXP=/usr/local/lib/perl5/5.6.1/BSDPAN -I../TSRM  -O -pipe 
> -march=pentium4 -I/usr/local/include -prefer-pic -c zend_execute_API.c
> 
> zend_execute_API.c: In function `zend_set_timeout':
> 
> zend_execute_API.c:782: storage size of `t_r' isn't known
> 
> zend_execute_API.c:788: `ITIMER_PROF' undeclared (first use in this 
> function)
> 
> zend_execute_API.c:788: (Each undeclared identifier is reported only once
> 
> zend_execute_API.c:788: for each function it appears in.)
> 
> zend_execute_API.c: In function `zend_unset_timeout':
> 
> zend_execute_API.c:806: storage size of `no_timeout' isn't known
> 
> zend_execute_API.c:810: `ITIMER_PROF' undeclared (first use in this 
> function)
> 
> *** Error code 1
> 
>  
> 
> Stop in /usr/ports/www/mod_php4/work/php-4.2.3/Zend.
> 
> *** Error code 1
> 
>  
> 
> Stop in /usr/ports/www/mod_php4/work/php-4.2.3.
> 
> *** Error code 1
> 
>  
> 
> Stop in /usr/ports/www/mod_php4.
> 
> *** Error code 1
> 
>  
> 
> Stop in /usr/ports/www/mod_php4.
> 
>  
> 
> Any help would greatly be appreciated, since this is a brand new server 
> that needs to be up and running ASAP.

Hi Muhannad,

I just need a little bit more information to help you, cause I didn't 
run into compiler errors but in linker errors.

Please send me your dmesg output and use the script(1) command to log 
your entire mod_php4 build process and send me that output, too.

And please do not expect fast answers. It's 3:45 am here and I'm going 
to sleep in near future :-)

Thanks,
Jens
-- 
L     i  W     W     W  i                 Jens Rehsack
L        W     W     W
L     i   W   W W   W   i  nnn    gggg    LiWing IT-Services
L     i    W W   W W    i  n  n  g   g
LLLL  i     W     W     i  n  n  g   g    Friesenstraße 2
                                   gggg    06112 Halle
                                      g
                                  g   g
Tel.:  +49 - 3 45 - 5 17 05 91    ggg     e-Mail: <rehsack@liwing.de>
Fax:   +49 - 3 45 - 5 17 05 92            http://www.liwing.de/



To Unsubscribe: send mail to majordomo@FreeBSD.org
with "unsubscribe freebsd-current" in the body of the message




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?3E03D10C.6030608>