Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 10 Jun 2018 09:48:24 +0100
From:      Steve O'Hara-Smith <steve@sohara.org>
To:        thor <thor@irk.ru>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Cannot mix incompatible Qt library (version 0x50904) with this library (version 0x50a01),Abort (core dumped)
Message-ID:  <20180610094824.f47483cedc99bbca6f2361f6@sohara.org>
In-Reply-To: <8196da8f-7299-64e1-25d7-ef371421440e@irk.ru>
References:  <8993e2f6-cf57-96d2-fd2c-7da63db08673@zyxst.net> <8196da8f-7299-64e1-25d7-ef371421440e@irk.ru>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sun, 10 Jun 2018 13:05:35 +0800
thor <thor@irk.ru> wrote:

> Then make "some proggie" observing that nothing including QT5 is built 
> as a prerequisite. If something is required then stop the build and 
> install the dependency from package.

	There's an easier way using the 'missing' make target that lists
all the packages needed by a port - on a system mostly populated with
packages build ports this way:

cd <port directory>
pkg install `make missing`
make install clean

-- 
Steve O'Hara-Smith <steve@sohara.org>



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20180610094824.f47483cedc99bbca6f2361f6>