Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 10 Aug 2007 22:30:01 +0200
From:      Erik Norgaard <norgaard@locolomo.org>
To:        Pollywog <lists-fbsd@shadypond.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: ldap server and client conflicts,	with Postfix and Courier in the mix
Message-ID:  <46BCCAC9.2070705@locolomo.org>
In-Reply-To: <200708102015.01023.lists-fbsd@shadypond.com>
References:  <200708102015.01023.lists-fbsd@shadypond.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Pollywog wrote:
> I want to install the LDAP server but it complains that it conflicts with LDAP 
> client:
> 
> ===>  openldap-server-2.3.37 conflicts with installed package(s):
>       openldap-client-2.3.37
> 
> However, attempting to remove the client to make room for the server results 
> in another complaint:
> 
> pkg_delete: package 'openldap-client-2.3.37' is required by these other 
> packages
> and may not be deinstalled:
> courier-authlib-ldap-0.59.3
> postfix-2.4.5,1

I think the conflict is mostly a question of the order things were 
installed. When you install the server then it also installs the client 
side which it can't because it's already there. But, ofcourse, these 
should not conflict.

This c(sh)ould be solved by deinstalling the listed packages and install 
the server, then the reinstall the remaining packages.

Alternatively, you can force deinstall the client or simply override the 
warning.

Cheers, Erik

-- 
Ph: +34.666334818                      web: http://www.locolomo.org



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?46BCCAC9.2070705>