Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 2 Feb 2007 23:08:29 -0800
From:      Gary Kline <kline@tao.thought.org>
To:        Joe Holden <joe@joeholden.co.uk>
Cc:        Gary Kline <kline@tao.thought.org>, FreeBSD Mailing List <freebsd-questions@freebsd.org>
Subject:   Re: firefox, mozilla won't display PHP (Was: Re: firefox, extensions, and *.php pages)
Message-ID:  <20070203070829.GA15799@thought.org>
In-Reply-To: <45C42DD2.5090606@joeholden.co.uk>
References:  <20070203005339.GA86991@thought.org> <20070203052818.GA13363@thought.org> <45C42DD2.5090606@joeholden.co.uk>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, Feb 03, 2007 at 06:38:10AM +0000, Joe Holden wrote:
> Gary Kline wrote:
> >On Fri, Feb 02, 2007 at 04:53:39PM -0800, Gary Kline wrote:
> >
> >
> >
> >	Well, the fact that my trying seever firefox addson and the 
> >	failure of firefox and mozilla to display my PHP  files just
> >	happened to be co-incident.  As of this writing, none of my
> >	browsers displays my php pages.   I am rebuilding php5; php4
> >	refuses to build.  
> >
> >	If anybody knows if I ought to be building php4, please let me
> >	know. --I've surfed the web looking for answers; so far,
> >	nothing-works....  
> >
> >	(*******)
> >
> >>	"You have chosen to open 
> >>
> >>	[ .... ]  (blank)
> >>
> >>	which is a: appplication/x-httpd-php
> >>	from http://www.thought.org
> >>
> >>	  What should Firefox do with this file?"
> >>
> >>	The one of three options *not* greyed out is:
> >>
> >>	(*) Save to Disk
> >>
> >>
> >>	What's going on?  And/or: how did I shoot myself in the foot?
> >>
> >>	thanks for any insights; a couple of these addon are useful...
> >>
> >>	gary
> >>
> 
> You've added AddType lines to config, but the module is missing, or 
> isn't being loaded presumably.



	Right; after a couple hours tracing, I find that for some reason,
	devel/libtool15 says that regex/regcomp.lo isn't valid.


	<output>
root@sage:/usr/ports/lang/php4/work/php-4.4.4# k
"Makefile", line 496: warning: duplicate script for target
"main/internal_functions.lo" ignored
/bin/sh /usr/local/bin/libtool --preserve-dup-deps --mode=link cc
-export-dynamic -pipe -g -Wall     regex/regcomp.lo regex/regexec.lo

	[[ ... ]

Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo
Zend/zend_strtod.lo Zend/zend_canary.lo Zend/zend_execute.lo
sapi/cgi/libfcgi/fcgi_stdio.lo sapi/cgi/libfcgi/fcgiapp.lo
sapi/cgi/libfcgi/os_unix.lo sapi/cgi/cgi_main.lo sapi/cgi/getopt.lo
main/internal_functions.lo -lcrypt -lcrypt -lm -lcrypt -lcrypt  -o
sapi/cgi/php
libtool: link: `regex/regcomp.lo' is not a valid libtool object
*** Error code 1

	</output>

	I have php4 and apache running on other servers, and there,
	when I point mozilla at a php file, it works, of course..
	--So: nothing to do with the "extensions"; for unknown reasons, 
	php4 will not build.   

	Has anybody else experienced this snufu??

	thanks, Joe.

	gary


> -- 
> Joe Holden
> Telephone: +44 (0) 207 100 9593
> Email: joe@joeholden.co.uk
> Website: http://www.joeholden.co.uk
> IRC: raindance@Quakenet/#FreeBSD
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"

-- 
  Gary Kline  kline@thought.org   www.thought.org  Public Service Unix




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20070203070829.GA15799>