Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 12 Jan 2008 15:34:31 -0800
From:      Chris Maness <chris@chrismaness.com>
To:        freebsd-questions@freebsd.org
Subject:   index.php not automatically displaying
Message-ID:  <47894E87.2020300@chrismaness.com>

Next in thread | Raw E-Mail | Index | Archive | Help
I have two web servers -- one old, and another I have just set up.  I 
have tried to set up the new http.conf the same for php files, but the 
new one does not automatically parse index.php like index.html.  This 
works on the old server, but not the new.

Here are what I think the relevant lines in http.conf:

#
# DirectoryIndex: Name of the file or files to use as a pre-written HTML
# directory index.  Separate multiple entries with spaces.
#
<IfModule mod_dir.c>
    <IfModule mod_php3.c>
        <IfModule mod_php4.c>
            DirectoryIndex index.php index.php3 index.html
        </IfModule>
        <IfModule !mod_php4.c>
            DirectoryIndex index.php3 index.html
        </IfModule>
    </IfModule>
    <IfModule !mod_php3.c>
        <IfModule mod_php4.c>
            DirectoryIndex index.php index.html
        </IfModule>
        <IfModule !mod_php4.c>
            DirectoryIndex index.html
        </IfModule>
    </IfModule>
    <IfModule !mod_php5.c>
        <IfModule mod_php5.c>
            DirectoryIndex index.php index.html
        </IfModule>
        <IfModule !mod_php5.c>
            DirectoryIndex index.html
        </IfModule>
    </IfModule>
</IfModule>
#
<IfModule mod_php5.c>
        AddType application/x-httpd-php .php
        AddType application/x-httpd-php-source .phps
</IfModule>
#
#

-- 
Chris Maness
(909) 223-9179
http://www.chrismaness.com




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?47894E87.2020300>