Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 2 Sep 2014 00:27:07 +0000
From:      meta <meta@vmeta.jp>
To:        Bryan Drewery <bdrewery@FreeBSD.org>
Cc:        ports@freebsd.org
Subject:   Re: pkg-fallout USE_PACKAGE_DEPENDS_ONLY and SIGERR?
Message-ID:  <0000014833c20a18-9eb4c74b-0b47-4763-870f-9dc93dbffb62-000000@us-west-2.amazonses.com>
In-Reply-To: <5400A6F0.60807@FreeBSD.org>
References:  <000001482096f9ef-dacf0525-2100-4a1d-a666-39af5177e083-000000@us-west-2.amazonses.com> <5400A6F0.60807@FreeBSD.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Bryan,

Thank you very much, I try to fix it.

On Fri, Aug 29, 2014 at 11:14:40AM -0500, Bryan Drewery wrote:
> On 8/29/2014 2:07 AM, Koichiro IWAO wrote:
> > Hello,
> > 
> > How can I fix following two pkg-fallout notifications?  The one of them
> > is about
> > dependency, another one is SIGERR.  I have no idea how to fix it. 
> > Please help.
> > 
> >> ===>   USE_PACKAGE_DEPENDS_ONLY set - not building missing dependency
> >> from source
> >> *** Error code 1
> >>
> >> Stop.
> >> make: stopped in /usr/ports/japanese/font-ricty
> > 
> >> ==>  Building for ja-font-ricty-discord-3.2.3
> >> cd
> >> /wrkdirs/usr/ports/japanese/font-ricty-discord/work/yascentur-Ricty-0fd7047
> >> &&
> >> /bin/sh
> >> /wrkdirs/usr/ports/japanese/font-ricty-discord/work/yascentur-Ricty-0fd7047/ricty_generator.sh
> >>
> >> /usr/local/lib/X11/fonts/OTF/Inconsolata.otf 
> >> /usr/local/lib/X11/fonts/TTF/migu-1m-regular.ttf
> >> /usr/local/lib/X11/fonts/TTF/migu-1m-bold.ttf
> >> Ricty Generator 3.2.3b
> >>
> >> Author: Yasunori Yusa <lastname at save.sys.t.u-tokyo.ac.jp>
> >>
> >> This script is to generate ``Ricty'' font from Inconsolata and Migu 1M.
> >> It requires 2-5 minutes to generate Ricty. Owing to SIL Open Font License
> >> Version 1.1 section 5, it is PROHIBITED to distribute the generated font.
> >>
> >> trap: bad signal ERR
> >> *** Error code 2
> >>
> 
> For ricty-discord:
> 
> The ricty_generator.sh script is using a bashism and expects to use bash
> as noted in at the top of the script.
> 
> font-ricty/Makefile is running with /bin/sh though:
>  56 do-build:
>  57         cd ${WRKSRC} &&\
>  58                 ${SH} ${WRKSRC}/ricty_generator.sh \
> 
> You'll need a BUILD_DEPENDS on bash and use ${LOCALBASE}/bin/bash rather
> than ${SH} there.
> 
> Or patch out whatever the trap is doing in the script.
> 
> I'm not sure how japanese/font-ricty has ever worked.
> 
> For font-ricty:
> 
> It is likely a false positive failure in a way. Because
> font-ricty-discord did not build it cannot build font-ricty either. It
> should have *skipped* trying, but it managed to try and found that its
> dependency was not built. Fix font-ricty-discord and it should fix
> font-ricty.
> 
> >> Stop in /usr/ports/japanese/font-ricty-discord.
> >> *** Error code 1
> > 
> > http://beefy2.isc.freebsd.org/data/10amd64-quarterly/2014-08-27_15h21m01s/logs/ja-font-ricty-3.2.3.log
> > 
> > http://beefy1.isc.freebsd.org/data/84i386-default/2014-08-15_14h18m35s/logs/ja-font-ricty-discord-3.2.3.log
> > 
> > 
> 
> 
> -- 
> Regards,
> Bryan Drewery
> 

-- 
`whois vmeta.jp | nkf -w`
meta <meta@vmeta.jp>



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?0000014833c20a18-9eb4c74b-0b47-4763-870f-9dc93dbffb62-000000>