Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 1 Feb 2009 14:58:22 -0600
From:      Scot Hetzel <swhetzel@gmail.com>
To:        "O. Hartmann" <ohartman@mail.zedat.fu-berlin.de>
Cc:        freebsd-current@freebsd.org, Mel <fbsd.questions@rachie.is-a-geek.net>, freebsd-questions@freebsd.org
Subject:   Re: Xorg upgrade desaster: Xlib: extension "Generic Event Extension" missing on display ":0.0".
Message-ID:  <790a9fff0902011258j5f954ea9s2c9665c3bd8a5c61@mail.gmail.com>
In-Reply-To: <4985877B.8080502@mail.zedat.fu-berlin.de>
References:  <49837CFD.4080603@mail.zedat.fu-berlin.de> <200901301430.07087.fbsd.questions@rachie.is-a-geek.net> <4984EF27.2050405@mail.zedat.fu-berlin.de> <790a9fff0901312008x71fa025na58856bde4c7a5be@mail.gmail.com> <4985877B.8080502@mail.zedat.fu-berlin.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sun, Feb 1, 2009 at 5:28 AM, O. Hartmann
<ohartman@mail.zedat.fu-berlin.de> wrote:
> Scot Hetzel wrote:
>> On Sat, Jan 31, 2009 at 6:39 PM, O. Hartmann
>> <ohartman@mail.zedat.fu-berlin.de> wrote:
>>
>>> build-process, but I doubt this. I did a 'ldd' on the Firefox3 binary
>>> and  I got the attached dump of the linked shared objects.
>>> Interestingly, the first three entries show up something missing -
>>> therefore I deinstalled Firefox and rebuild the browser after an
>>> additional rebuild of libxcb (via portupgrade -rf). Previously, all Xorg
>>>
>>
>>
>>> thor# ldd firefox-bin
>>> firefox-bin:
>>>        libxul.so => not found (0x0)
>>>        libmozjs.so => not found (0x0)
>>>        libxpcom.so => not found (0x0)
>>>        libplds4.so.1 => /usr/local/lib/libplds4.so.1 (0x80063e000)
>>>        libplc4.so.1 => /usr/local/lib/libplc4.so.1 (0x80076f000)
>>>
>>
>> When firefox3 was first added to the ports collection, I had noticed
>> this problem with firefox3 (after using sysutils/libchk), but I didn't
>> have this problem with the firefox 2.  A look at the difference
>> between the www/firefox and www/firefox3 Makefiles showed that
>> firefox3 was missing this:
>>
>> LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
>>
>> After adding this line to the ports Makefile, and rebuilding the port,
>> these libraries are now showing as found in the ldd output.
>>
>> Scot
>>
> Isn't that worth a PR?
>
>
Submitted and rejected:

http://www.freebsd.org/cgi/query-pr.cgi?pr=131237

As it doesn't affect the operation of Firefox3's firefox-bin program.

Scot



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?790a9fff0902011258j5f954ea9s2c9665c3bd8a5c61>