Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 18 May 2007 09:33:46 -0400 (EDT)
From:      "Tuc at T-B-O-H.NET" <ml@t-b-o-h.net>
To:        freebsd-questions@freebsd.org
Subject:   How to replace perl-threaded with perl?
Message-ID:  <200705181333.l4IDXksq051985@himinbjorg.tucs-beachin-obx-house.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi,

	I installed lang/perl5.8 and set it to be threaded. I'm having
problems getting mod_perl working, and I know at one time atleast that
it was because of using threaded perl. How do I portupgrade and tell it
to :

1) Uninstall perl-threaded-5.8.8
2) Install perl 5.8
3) Make sure no previous shared libs are saved
4) Recompile everything that depended previously on perl-threaded and now
	depends on perl 5.8

	I looked at portupgrade, and for #1/#2 I see the "-o" syntax, but
am not sure if it works correctly in this instance. For #3, it would be
the "-u" syntax, correct? And then for #4 be "-fr"?


			Thanks, Tuc



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200705181333.l4IDXksq051985>