Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 01 Dec 2017 13:04:36 +0100
From:      Marek Krawczyk <marek@mky.waw.pl>
To:        FreeBSD <freebsd-questions@freebsd.org>
Cc:        "koobs@FreeBSD.org" <koobs@freebsd.org>, owner-freebsd-questions@freebsd.org, Carmel NY <carmel_ny@outlook.com>
Subject:   Re: PROBLEM: Another instance of Certbot is already running.
Message-ID:  <553fa03e7865a31ac5cf789c7e537a1d@mky.waw.pl>
In-Reply-To: <BN6PR2001MB173089394EF9783804DB692B80390@BN6PR2001MB1730.namprd20.prod.outlook.com>
References:  <BN6PR2001MB173089394EF9783804DB692B80390@BN6PR2001MB1730.namprd20.prod.outlook.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi!

W dniu 2017-12-01 12:27, Carmel NY napisaƂ(a):
> FreeBSD 11.1 RELEASE-p5
> 
> I have been using the p5-certbot port without a problem until
> recently. It is being run via cron:  /usr/local/bin/certbot -q renew
> --pre-hook "service dovecot stop" --post-hook "service dovecot start".
> Until recently that worked fine. Now I have started receiving this
> error message:  "Another instance of Certbot is already running." Try
> as I might, I cannot find another instance of "certbot" running.
> 
> Apparently, the only way to correct the problem is to reboot the
> system. This only works until after the cron command has run one time,
> after which the problem resurfaces. I am hoping that someone might
> have a suggestion.

I have the same issue with dovecot. The certbot is waiting on
the post-hook command, but only when it was ran from cron.
If it is running from the shell, the dovecot is restarted properly.
Unfortunatelly I did not found solution for this but I can also
confirm that the issue exist.

Regards,
Marek



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?553fa03e7865a31ac5cf789c7e537a1d>