Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 25 Jun 2013 09:34:00 -0500
From:      Mark Felder <feld@feld.me>
To:        freebsd-questions@freebsd.org
Subject:   Re: Should I be able to use mergemaster with freebsd-update?
Message-ID:  <1372170840.16581.140661248284361.773B78EC@webmail.messagingengine.com>
In-Reply-To: <201306250814.r5P8Eo4Z077311@chilled.skew.org>
References:  <201306250814.r5P8Eo4Z077311@chilled.skew.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Tue, Jun 25, 2013, at 3:14, Mike Brown wrote:
> 
> Well, thanks for reading this far. I'm scared to death to reboot now,
> since my
> server is in another city, but we'll see how it goes.
> 

I always avoid freebsd-update when moving between releases simply
because of this atrocity.

If it requires we setup a stupid kickstarter to fund a developer to sit
down and rip into freebsd-update so it uses mergemaster I would be
incredibly thankful. I don't know how anyone can upgrade between FreeBSD
releases without an /etc/mergemaster.rc with the following settings:

AUTO_INSTALL='yes'
AUTO_UPGRADE='yes'
# keep our custom motd
IGNORE_FILES='/etc/motd'
# Do not display changes that only affect whitespace
DIFF_FLAG='-Bub'
FREEBSD_ID='yes'
DELETE_STALE_RC_FILES='yes'



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?1372170840.16581.140661248284361.773B78EC>