Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 24 Nov 2006 21:30:39 -0700
From:      service <service@fixer.com>
To:        questions@freebsd.org
Subject:   packages failing to load
Message-ID:  <4567C6EF.4040008@fixer.com>

Next in thread | Raw E-Mail | Index | Archive | Help
uname -a
FreeBSD localhost 5.4-RELEASE FreeBSD 5.4-RELEASE #0: Fri Nov 24 
08:54:35 UTC 2006     root@:/usr/src/sys/i386/compile/VIL  i386
----------------------------------------------------------------------------

I had FreeBSD-5.4 for about one and a half years.  Loading packages with 
"pkg_add -r" was very easy.  Suddenly "pkg_add -r" no longer works.

Looking at freebsd's ftp sites, they got rid of the 5.4 release.  They 
now have a 5.5 release.  I tried downloading from "packages-5-stable" 
and "packages-5.5-stable".  About 50 percent of these programs fail.  I 
get error messages that say something like  "/libexec/ld-elf.so.1: 
Shared object "libexpat.so.6" not found".  I'm not sure, but I think 
files ending in "so.6", belong in version 6, not version 5.  I have more 
than 10 versions of FreeBSD.  I tried using packages off these CDs.  
some of them worked, but most of the time I keep getting error messages.

What can I do?

Thanks in advance,
bruce




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4567C6EF.4040008>