Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 28 Apr 2020 22:42:30 -0400
From:      Robert Huff <roberthuff@rcn.com>
To:        ajtiM <starikarp@dismail.de>
Cc:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Firefox 76.0,1
Message-ID:  <24232.59798.585406.321666@jerusalem.litteratus.org>
In-Reply-To: <20200428191142.5cf10bbc@dismail.de>
References:  <20200428191142.5cf10bbc@dismail.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

ajtiM via freebsd-questions writes:

>  I do not have installed Python 2.7 but today I want to update Firefox
>  to version 76.0,1 and it pull me Python 2.7.
>  I have checkmarks on DBUS, FFMPEG, GCONF, OPTIMAZED_CFLAGS, PROFILE and
>  SNDIO.
>   make
>  ===>   firefox-76.0,1 depends on package: nspr>=4.25 - found
>  ===>   firefox-76.0,1 depends on package: nss>=3.51.1 - found
>  ===>   firefox-76.0,1 depends on package: icu>=64.1,1 - found
>  ===>   firefox-76.0,1 depends on package: libevent>=2.1.8 - found
>  ===>   firefox-76.0,1 depends on package: harfbuzz>=2.6.4 - found
>  ===>   firefox-76.0,1 depends on package: graphite2>=1.3.14 - found
>  ===>   firefox-76.0,1 depends on package: png>=1.6.35 - found
>  ===>   firefox-76.0,1 depends on package: libvpx>=1.8.2 - found
>  ===>   firefox-76.0,1 depends on package: py37-sqlite3>0 - found
>  ===>   firefox-76.0,1 depends on package: v4l_compat>0 - found
>  ===>   firefox-76.0,1 depends on executable: autoconf-2.13 - found
>  ===>   firefox-76.0,1 depends on executable: nasm - found
>  ===>   firefox-76.0,1 depends on executable: yasm - found
>  ===>   firefox-76.0,1 depends on executable: zip - found
>  ===>   firefox-76.0,1 depends on package: llvm90>0 - found
>  ===>   firefox-76.0,1 depends on package: rust-cbindgen>=0.13.1 - found
>  ===>   firefox-76.0,1 depends on package: rust>=1.41 - found
>  ===>   firefox-76.0,1 depends on file: /usr/local/bin/python3.7 - found
>  ===>   firefox-76.0,1 depends on executable: node - found
>  ===>   firefox-76.0,1 depends on file: /usr/local/bin/clang90 - found
>  ===>   firefox-76.0,1 depends on package: libnotify>0 - found
>  ===>   firefox-76.0,1 depends on file: /usr/local/include/sndio.h -
>  found ===>   firefox-76.0,1 depends on executable: gmake - found
>  ===>   firefox-76.0,1 depends on package: libiconv>=1.14_11 - found
>  ===>   firefox-76.0,1 depends on package: pkgconf>=1.3.0_1 - found
>  ===>   firefox-76.0,1 depends on file: /usr/local/bin/python2.7 - not

	_If_ I have this right:
	Firefox requires pkgconf ... which - if DOCS=yes - requires
ImageMagic ... which requires (in your case) python 2.7.
	See if you can rebuild your versiou of ImageMagic against python
3.7, and this should go away.



			Respectfully,


				Robert Huff



-- 

Get it right: _physical_ distancing; _social_ cohesion



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?24232.59798.585406.321666>