Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 11 Aug 2007 13:03:32 -0500
From:      "Scot Hetzel" <swhetzel@gmail.com>
To:        "Hajimu UMEMOTO" <ume@freebsd.org>
Cc:        krion@freebsd.org, Xin LI <delphij@delphij.net>, freebsd-questions@freebsd.org, freebsd-ports@freebsd.org
Subject:   Re: request add db45/db46 support to mail/exim port
Message-ID:  <790a9fff0708111103y2c178125iacc5d4ec1395bb07@mail.gmail.com>
In-Reply-To: <yge1weadkp7.wl%ume@mahoroba.org>
References:  <70f41ba20708110931i4262c224kd0479290616c4fa8@mail.gmail.com> <46BDEA06.9030503@delphij.net> <70f41ba20708111013g296134ecw57bf152846718e91@mail.gmail.com> <790a9fff0708111037m1d25e164ma760a286f6d70cb8@mail.gmail.com> <yge1weadkp7.wl%ume@mahoroba.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 8/11/07, Hajimu UMEMOTO <ume@freebsd.org> wrote:
> Hi,
>
> >>>>> On Sat, 11 Aug 2007 12:37:18 -0500
> >>>>> "Scot Hetzel" <swhetzel@gmail.com> said:
>
> swhetzel> Here's the correct code for BDB detection:
>
> swhetzel> USE_BDB= 40+
>
> Why do you specify USE_BDB as 40+, explicitly?  Since, it is defined
> as 41+ in bsd.database.mk, I believe USE_BDB=yes is enough.
>
I believe when I made the change to bsd.database.mk, and then patched
all of the BDB using ports, I had put the lowest version that the port
 supported into USE_BDB.

USE_BDB=yes would also work and allow the port to show a dependancy on
the default BDB version instead of the lowest BDB version.  Also,
INVALID_BDB_VER takes care of excluding BDB versions that the port
doesn't work with.

Scot

-- 
DISCLAIMER:
No electrons were mamed while sending this message. Only slightly bruised.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?790a9fff0708111103y2c178125iacc5d4ec1395bb07>