Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 07 Jul 2007 11:19:07 -0700
From:      Norbert Papke <fbsd-ml@scrapper.ca>
To:        freebsd-questions@freebsd.org
Cc:        Olivier Nicole <on@cs.ait.ac.th>
Subject:   Re: Lost SSH X1 Forwarding with Xorg 7.2
Message-ID:  <200707071119.08024.fbsd-ml@scrapper.ca>
In-Reply-To: <200707051000.l65A0Wiq015761@banyan.cs.ait.ac.th>
References:  <200707051000.l65A0Wiq015761@banyan.cs.ait.ac.th>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On July 5, 2007, Olivier Nicole wrote:
> A nice *feature* that I just noticed, I apologize if it has been
> mentionned earlier.
>
> xorg 7.2 tends to install all the components in /usr/loca insteal of
> the traditional /usr/X11R6.
>
> But sshd is still expecting xauth to be in /usr/X11R6/bin/xauth; so
> sshd_config has to be modified to reflect the fact that xauth new path
> is /usr/local/bin/xauth.
>
> So the default /etc/ssh/sshd_config should be adapted to reflect this
> change...

The default location in /usr/X11R6/bin/xauth should still work with the 
symlink in place.

However, I had a similar problem to yours.  Having tracked 7.2 for some time, 
I had "X11BASE=${LOCALBASE}" in /etc/make.conf.  When building sshd, 
LOCALBASE is not defined and X11BASE ends up being the empty string.  This 
then caused XAUTH_PATH to be set to /bin/xauth which, of course, does not 
exist.  Removing the statement from /etc/make.conf fixed this -- it isn't 
required anymore.

Cheers.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200707071119.08024.fbsd-ml>