Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 23 Feb 2005 20:34:26 +0100
From:      Anthony Atkielski <atkielski.anthony@wanadoo.fr>
To:        freebsd-questions@freebsd.org
Subject:   Re: Different OS's? Marketshare
Message-ID:  <1505159320.20050223203426@wanadoo.fr>
In-Reply-To: <200502231419.54629.m.hauber@mchsi.com>
References:   <!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAAkUru9e0Xgkm1jphiEj0758KAAAAQAAAAVNKPkcwi5Uq3w6wWDp/biAEAAAAA@video-phones-evdo.com> <20050223104701.3981c839@jacob.6texans.net> <200502231419.54629.m.hauber@mchsi.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Mike Hauber writes:

> What kind of problems are you having with FreeBSD?  There was a
> non-specific mention of errors regarding your hard drive, but 
> said everything was working ok.

I mentioned the main error in a separate thread: After successfully
installing the OS, I simply cannot persuade the machine to boot from the
hard disk.  It just blanks the screen and stops.  It must be booting
_something_, because it normally puts up an error message if it cannot
find the boot information it expects.  So I presume it's passing control
to garbage read from the disk and this is halting the system silently.

If I boot from floppy, no problem.  And if I boot from the install
floppy and then enter the loader, unload the kernel, switch the current
device to my boot disk (the hard disk), and boot from the loader, it
comes up instantly.  So there is some part of the boot process that's
not working.

I installed FreeBSD with a standard MBR on both disks, and I set the
first disk to "bootable," but this doesn't seem to help, although I'm
still trying.

The other problem I have is SCSI errors that generate massive streams of
console error messages, although they don't appear to be errors that
cause data loss.  I got these while moving ports onto my machine.  Now
that I think about it, I think it might be a conflict with an old ISDN
card that is still mounted in the machine ... hmm.  Anyway, that's
secondary.

> Whoa...  I installed Mandrake 9 when it released and it did the
> same thing.  I thought my cd burner had fried.  When I got 
> another one, it worked fine for both.

I "fixed" this, somehow.  I turned on my SCSI devices (a CD burner, a
scanner, and a tape drive), and then FreeBSD saw the IDE CD-ROM drive.
Go figure.  Actually, it seemed to see the CD-ROM at boot, but it
wouldn't see it when it asked for install media.  It sees it after boot
even with the SCSI devices turned off.  Very mysterious.

I'm sure there are no hardware problems on this machine; it has been
running flawlessly for eight years.  So anything that doesn't work is
software.

> (I like the drake, though...  It's what I usually recommend for
> people who are wanting to try something other than windows and 
> don't have the knowledge (desire to learn) necessary to build up 
> a system of their own).

I'm still quite ambivalent about it.  I keep wondering if Linux is
different enough and useful enough to be worth dedicating this machine
to it ... or if I should just continue with FreeBSD and install X on the
machine (and KDE, probably, since it seems to be popular, although I
welcome suggestions).

Which window manager is the closest to classic UNIX window managers (as
opposed to wannabe Windows products)?

-- 
Anthony




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?1505159320.20050223203426>